aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-datetime-calendar-julian
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-01 17:45:15 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-01 17:45:17 +0000
commitccca3236711b56d6ecc58247063a4e4f51c80476 (patch)
treee36f3bc0f90ed33dda3f9f5c5db143eef78d8c3c /community/perl-datetime-calendar-julian
parent08c37535977c75460de510b473e579b299a934b0 (diff)
community/perl-d*: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - Rename _builddir to builddir - Add missing default_prepare in prepare() - Remove old checksums
Diffstat (limited to 'community/perl-datetime-calendar-julian')
-rw-r--r--community/perl-datetime-calendar-julian/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/community/perl-datetime-calendar-julian/APKBUILD b/community/perl-datetime-calendar-julian/APKBUILD
index 0e72d20e65d..1ec4cfc70c4 100644
--- a/community/perl-datetime-calendar-julian/APKBUILD
+++ b/community/perl-datetime-calendar-julian/APKBUILD
@@ -4,13 +4,13 @@
pkgname=perl-datetime-calendar-julian
_pkgreal=DateTime-Calendar-Julian
pkgver=0.04
-pkgrel=0
+pkgrel=1
pkgdesc="DateTime object in the Julian calendar"
url="http://search.cpan.org/dist/DateTime-Calendar-Julian/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends="perl-datetime"
-cpanmakedepends=" "
+cpanmakedepends=""
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
@@ -18,7 +18,7 @@ source="http://search.cpan.org/CPAN/authors/id/P/PI/PIJLL/$_pkgreal-$pkgver.tar.
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
@@ -28,15 +28,18 @@ prepare() {
build() {
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="de688324eb33a27449ac2a5bfe1453a0 DateTime-Calendar-Julian-0.04.tar.gz"
-sha256sums="bb5968ad18bcd0772d2c311cd2deb23b777475ea05aa1099688247cd27a5000e DateTime-Calendar-Julian-0.04.tar.gz"
sha512sums="e822d57dabbf76dcca9dc1eb097cef9c15579aeb1782a51eb3dd01d47eda0aef2aa92096df67602297a24c387445f6eb381bb3eedfe33486990844f3c96b4960 DateTime-Calendar-Julian-0.04.tar.gz"