aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-dist-checkconflicts
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-01 17:45:15 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-01 17:45:17 +0000
commitccca3236711b56d6ecc58247063a4e4f51c80476 (patch)
treee36f3bc0f90ed33dda3f9f5c5db143eef78d8c3c /community/perl-dist-checkconflicts
parent08c37535977c75460de510b473e579b299a934b0 (diff)
community/perl-d*: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - Rename _builddir to builddir - Add missing default_prepare in prepare() - Remove old checksums
Diffstat (limited to 'community/perl-dist-checkconflicts')
-rw-r--r--community/perl-dist-checkconflicts/APKBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/community/perl-dist-checkconflicts/APKBUILD b/community/perl-dist-checkconflicts/APKBUILD
index 577a4641300..9bfa7438acc 100644
--- a/community/perl-dist-checkconflicts/APKBUILD
+++ b/community/perl-dist-checkconflicts/APKBUILD
@@ -4,38 +4,43 @@
pkgname=perl-dist-checkconflicts
_pkgreal=Dist-CheckConflicts
pkgver=0.11
-pkgrel=0
-pkgdesc="declare version conflicts for your dist"
+pkgrel=1
+pkgdesc="Declare version conflicts for your dist"
url="http://search.cpan.org/dist/Dist-CheckConflicts/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends="perl-list-moreutils perl-module-runtime"
-cpanmakedepends=" perl-test-fatal "
+cpanmakedepends="perl-test-fatal"
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/D/DO/DOY/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ default_prepare
+
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="c8725a92b9169708b0f63036812070f2 Dist-CheckConflicts-0.11.tar.gz"
-sha256sums="ea844b9686c94d666d9d444321d764490b2cde2f985c4165b4c2c77665caedc4 Dist-CheckConflicts-0.11.tar.gz"
sha512sums="6c3f8546c1c7904bbc2a3c1135d145cbff95997c3032e9129afc98bdd98578dd9219af444f357dd8e9b1f08442a2fdd9d6f7fe8768f8ef165e71570f5ae246ad Dist-CheckConflicts-0.11.tar.gz"