aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-graphviz
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-22 23:44:54 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-22 23:44:56 +0000
commit309f6e65d8ddfeb8189f9bfb85e960d5ebbfc09e (patch)
tree8285479a453f1a00a2b7a57fd888d5758a382633 /community/perl-graphviz
parent3203ab3332b63ed5ab432420cb6897ddacfd729b (diff)
community/perl-[g-h]*: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - Rename _builddir to builddir - Add missing default_prepare in prepare()
Diffstat (limited to 'community/perl-graphviz')
-rw-r--r--community/perl-graphviz/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/community/perl-graphviz/APKBUILD b/community/perl-graphviz/APKBUILD
index 5b9c16d9779..e156dd45e4f 100644
--- a/community/perl-graphviz/APKBUILD
+++ b/community/perl-graphviz/APKBUILD
@@ -4,41 +4,46 @@
pkgname=perl-graphviz
_pkgreal=GraphViz
pkgver=2.24
-pkgrel=0
+pkgrel=1
pkgdesc="Interface to AT&T's GraphViz. Deprecated. See GraphViz2"
url="http://search.cpan.org/dist/GraphViz/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends="perl-libwww perl-file-which perl-xml-twig perl-xml-xpath
perl-ipc-run perl-parse-recdescent perl-module-build perl-test2-suite"
-cpanmakedepends="perl-test-pod "
+cpanmakedepends="perl-test-pod"
depends="$cpandepends"
makedepends="perl-dev graphviz $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/R/RS/RSAVAGE/$_pkgreal-$pkgver.tgz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ default_prepare
+
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="b57b32444e73d24cf9c374bf38bad699 GraphViz-2.24.tgz"
-sha256sums="d95efac4cdeedb18283100efe3e00c59c1add524d9ce88c1c8a358359122f5ad GraphViz-2.24.tgz"
sha512sums="b37d1303c243a306443d5adf35d597f4e259cedaa7956d80bdb47cba811ce94e63da6b42a23d192fa9da628d999f1c023911f3f956a575aeabe673f77f3f01d9 GraphViz-2.24.tgz"