aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-ima-dbi
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-12 02:15:36 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-12 02:16:13 +0000
commit5adff0b77c5d710bcc7ed4b4c5eb2080a23b2064 (patch)
tree8f78d3eaae7a57736bed0b879036677a3762ae72 /community/perl-ima-dbi
parentcb5921909815c262d070c1ff149bb9790ae311d1 (diff)
community/perl-[i-j]*: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - rename _builddir to builddir - add missing default_prepare in prepare()
Diffstat (limited to 'community/perl-ima-dbi')
-rw-r--r--community/perl-ima-dbi/APKBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/community/perl-ima-dbi/APKBUILD b/community/perl-ima-dbi/APKBUILD
index 480c83dc5dd..da9e4e7bb52 100644
--- a/community/perl-ima-dbi/APKBUILD
+++ b/community/perl-ima-dbi/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-ima-dbi
_pkgreal=Ima-DBI
pkgver=0.35
-pkgrel=1
+pkgrel=2
pkgdesc="unknown"
url="http://search.cpan.org/dist/Ima-DBI/"
arch="noarch"
@@ -16,21 +16,28 @@ makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/P/PE/PERRIN/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ default_prepare
+
+ cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
- make && make test
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}