aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-lwp-protocol-https
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-19 14:11:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-25 12:34:11 +0000
commit9e1f7fb9e716a8d32eac29904f07d0f87c55321d (patch)
tree24d35f50c1ae35b77c732999f79189f5031adbcc /community/perl-lwp-protocol-https
parent3ad0ce721373732d19c97d2d05045e5df99bc7f3 (diff)
community/perl-lwp-protocol-https: move from main
It is not required by any package from main
Diffstat (limited to 'community/perl-lwp-protocol-https')
-rw-r--r--community/perl-lwp-protocol-https/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/community/perl-lwp-protocol-https/APKBUILD b/community/perl-lwp-protocol-https/APKBUILD
new file mode 100644
index 00000000000..9b3124ad4b8
--- /dev/null
+++ b/community/perl-lwp-protocol-https/APKBUILD
@@ -0,0 +1,45 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=perl-lwp-protocol-https
+_pkgreal=LWP-Protocol-https
+pkgver=6.07
+pkgrel=0
+pkgdesc="Provide https support for LWP::UserAgent"
+url="http://search.cpan.org/dist/LWP-Protocol-https/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-libwww perl-io-socket-ssl perl-mozilla-ca perl-net-http
+ perl-net-ssleay"
+cpanmakedepends="perl-try-tiny"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+checkdepends="perl-test-requiresinternet"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/O/OA/OALDERS/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="4a07cd8a1c44e31781069a632a77f3af43747933420e831b4fd4a12faac7dc04f0c6b10ea773c3e14ecb66209a547b3587c0e3f481a55b9929db65f7b10343aa LWP-Protocol-https-6.07.tar.gz"