aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-moo
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-07-06 11:31:07 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-07-06 11:31:38 +0000
commitcb2326db70e5fd238e985d18b55c6650d8ef3876 (patch)
tree1512ec19ae4a591ef4543ae531ad5e75161b26cb /community/perl-moo
parent82160438cc7f001d4098f4dfd68278ffca7e0aec (diff)
community/perl-moo: upgrade to 2.003002
Diffstat (limited to 'community/perl-moo')
-rw-r--r--community/perl-moo/APKBUILD39
1 files changed, 23 insertions, 16 deletions
diff --git a/community/perl-moo/APKBUILD b/community/perl-moo/APKBUILD
index 31fcc538547..dad19fb9839 100644
--- a/community/perl-moo/APKBUILD
+++ b/community/perl-moo/APKBUILD
@@ -1,41 +1,48 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 2
# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
pkgname=perl-moo
_pkgreal=Moo
-pkgver=2.001001
+pkgver=2.003002
pkgrel=0
-pkgdesc="Minimalist Object Orientation (with Moose compatiblity)"
+pkgdesc="Minimalist Object Orientation (with Moose compatibility)"
url="http://search.cpan.org/dist/Moo/"
arch="noarch"
license="GPL PerlArtistic"
-cpandepends="perl-class-method-modifiers perl-role-tiny perl-strictures perl-devel-globaldestruction perl-module-runtime"
-cpanmakedepends="perl-test-fatal "
+cpandepends="perl-module-runtime perl-sub-quote perl-role-tiny perl-devel-globaldestruction perl-class-method-modifiers"
+cpanmakedepends=""
+cpancheckdepends="perl-test-fatal"
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
+checkdepends="perl-strictures $cpancheckdepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/H/HA/HAARG/$_pkgreal-$pkgver.tar.gz"
-
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="8daed3e18c927d72331c51cbeffda193 Moo-2.001001.tar.gz"
-sha256sums="a68155b642f389cb1cc40139e2663d0c5d15eb71d9ecb0961623a73c10dd8ec0 Moo-2.001001.tar.gz"
-sha512sums="04e246d7dd7eab614af74fa86a8be1288e432608015d3083d1b0b9ac1fca461f895d50b51aa63378a16068b80eb4d858f4edd56c0cc0c54bb53a70c8b524d523 Moo-2.001001.tar.gz"
+check() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+sha512sums="103878f4f4b0863125eff67e7a1a24525c565d28ee78eb3f54306daf3bcd6e949f5c451ca3e79448b2f66a74e8f942181c4af7aa79c23b3591ef4331d853ea2d Moo-2.003002.tar.gz"