aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-readonly
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 13:07:06 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 13:31:30 +0000
commit3ce302210e5b0a911d9657215d691b8fe4e5b9b5 (patch)
tree778ae8d17fb65f669c60b8d5eeeb3aa43bb87d58 /community/perl-readonly
parenta439676586c0e22b38559c0cfb70d81123930b3a (diff)
community/perl-[n-s]*: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - rename _builddir to builddir - add missing default_prepare in prepare()
Diffstat (limited to 'community/perl-readonly')
-rw-r--r--community/perl-readonly/APKBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/community/perl-readonly/APKBUILD b/community/perl-readonly/APKBUILD
index 1aa6d4cb2e8..2764b181de6 100644
--- a/community/perl-readonly/APKBUILD
+++ b/community/perl-readonly/APKBUILD
@@ -3,7 +3,7 @@
pkgname=perl-readonly
_pkgname=Readonly
pkgver=2.05
-pkgrel=0
+pkgrel=1
pkgdesc="Facility for creating read-only scalars, arrays, hashes"
url="https://github.com/sanko/readonly"
arch="noarch"
@@ -14,21 +14,26 @@ source="https://cpan.metacpan.org/authors/id/S/SA/SANKO/$_pkgname-$pkgver.tar.gz
builddir="$srcdir/$_pkgname-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- perl Build.PL --installdirs=vendor || return 1
+ perl Build.PL --installdirs=vendor
}
build() {
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- ./Build && ./Build test
+ ./Build
+}
+
+check() {
+ cd "$builddir"
+ ./Build test
}
package() {
cd "$builddir"
- ./Build install --destdir="$pkgdir" || return 1
+ ./Build install --destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}