aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-tree-simple
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-27 06:36:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-27 13:48:01 +0000
commit1239188b53dbacb27d587c51e3fbbbc4a459c444 (patch)
tree5889dbc6347349d0a6294f8c78103aaa60ae698a /community/perl-tree-simple
parent3addf540176dda33a4a55ff403ff5a2c3af9b7cd (diff)
community/perl-tree-simple: move from main
perl-tree-simple is required only by rt4 package and it is part of community.
Diffstat (limited to 'community/perl-tree-simple')
-rw-r--r--community/perl-tree-simple/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/perl-tree-simple/APKBUILD b/community/perl-tree-simple/APKBUILD
new file mode 100644
index 00000000000..64bfb7fb259
--- /dev/null
+++ b/community/perl-tree-simple/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-tree-simple
+_pkgreal=Tree-Simple
+pkgver=1.33
+pkgrel=0
+pkgdesc="Tree::Simple Perl module"
+url="https://metacpan.org/release/Tree-Simple"
+arch="noarch"
+license="GPL+ or Artistic"
+cpandepends="perl-test-exception"
+depends="perl $cpandepends"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/R/RS/RSAVAGE/$_pkgreal-$pkgver.tgz"
+
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="bec140fa723a8fadc65d2d8dc88c73295b346bc1583bfb031f2851cf80cddaea9b3e5e38225bbd7ac2e3e29006efb5bbac95b678090ba62714dfd6a306000b25 Tree-Simple-1.33.tgz"