aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-xml-xpath
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 01:16:36 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 01:39:35 +0000
commitb1274f164d3742fc5a47f4ab85a91baef72338ec (patch)
tree7095e084822242b5cff89ac35bb3dee624642067 /community/perl-xml-xpath
parent4c6f8e1fdf89d2899b81dd6a680a65e89e20b7a9 (diff)
community/perl-[t-y]: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - rename _builddir to builddir
Diffstat (limited to 'community/perl-xml-xpath')
-rw-r--r--community/perl-xml-xpath/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/community/perl-xml-xpath/APKBUILD b/community/perl-xml-xpath/APKBUILD
index b5535184f26..08533871c7b 100644
--- a/community/perl-xml-xpath/APKBUILD
+++ b/community/perl-xml-xpath/APKBUILD
@@ -4,8 +4,8 @@
pkgname=perl-xml-xpath
_pkgreal=XML-XPath
pkgver=1.40
-pkgrel=0
-pkgdesc="a set of modules for parsing and evaluating XPath statements"
+pkgrel=1
+pkgdesc="A set of modules for parsing and evaluating XPath statements"
url="http://search.cpan.org/dist/XML-XPath/"
arch="noarch"
license="GPL PerlArtistic"
@@ -24,7 +24,12 @@ prepare() {
build() {
cd "$builddir"
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {