aboutsummaryrefslogtreecommitdiffstats
path: root/community/pgimportdoc
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-09 00:32:31 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-09 00:32:31 +0200
commit204fcfaa4b3de6ca29441648a1e08107eb7bbe0d (patch)
treeba712ab282e7fb6392a754a1ed2e165ede0c0548 /community/pgimportdoc
parent892b84513da1fa92851451adbc703575748bcef3 (diff)
community/pgimportdoc: move from testing
Diffstat (limited to 'community/pgimportdoc')
-rw-r--r--community/pgimportdoc/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/pgimportdoc/APKBUILD b/community/pgimportdoc/APKBUILD
new file mode 100644
index 00000000000..8e77418bfed
--- /dev/null
+++ b/community/pgimportdoc/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=pgimportdoc
+pkgver=0.1.2
+pkgrel=0
+pkgdesc="CLI tool for import XML, TEXT and BYTEA documents to PostgreSQL"
+url="https://github.com/okbob/pgimportdoc"
+arch="all"
+license="BSD"
+makedepends="libedit-dev libxml2-dev postgresql-dev zlib-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/okbob/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make USE_PGXS=1 all
+}
+
+check() {
+ cd "$builddir"
+ ./pgimportdoc -V
+}
+
+package() {
+ cd "$builddir"
+ make USE_PGXS=1 DESTDIR="$pkgdir" install
+}
+
+sha512sums="f4e0cba9ec81bebb8530a290528c238c8aa16730f6adc89843db75e143e66262b72ac791e943df9d5897eea90c29638b161d7ca08793692d1b5e7d2c1d99286c pgimportdoc-0.1.2.tar.gz"