aboutsummaryrefslogtreecommitdiffstats
path: root/community/phonon/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-18 09:50:50 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-18 09:57:43 +0000
commit572a532d73b12b6de9dd62affa0d2834cf120f7c (patch)
tree52480e002bc5c0e118038d1fa0da001f0946f67b /community/phonon/APKBUILD
parent34e75aaf1932b2bdcaae92122d06f45fa1033acc (diff)
community/phonon: moved from main, added maintainer
Diffstat (limited to 'community/phonon/APKBUILD')
-rw-r--r--community/phonon/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/community/phonon/APKBUILD b/community/phonon/APKBUILD
new file mode 100644
index 00000000000..707e85be4d2
--- /dev/null
+++ b/community/phonon/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=phonon
+pkgver=4.8.1
+pkgrel=0
+pkgdesc="KDE multimedia backend"
+url="http://phonon.kde.org/"
+arch="all"
+license="LGPL"
+depends=
+depends_dev="qt-dev glib-dev"
+makedepends="$depends_dev cmake automoc4"
+install=""
+subpackages="$pkgname-dev"
+source="http://download.kde.org/stable/phonon/${pkgver}/phonon-$pkgver.tar.xz"
+
+_builddir="$srcdir"/phonon-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ mkdir -p "$_builddir"/build
+}
+
+build() {
+ cd "$_builddir"/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT=FALSE \
+ -DDBUS_INTERFACES_INSTALL_DIR=/usr/share/dbus-1/interfaces \
+ -Wno-dev \
+ "$_builddir" || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"/build
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="2da3a26b911b23bb29d6ba2d07044a08 phonon-4.8.1.tar.xz"
+sha256sums="b6ca0126cd5330731875acc1cc0b60f8c9ed7ebc71e1d0210b74bf21658027d1 phonon-4.8.1.tar.xz"
+sha512sums="98a69fbc8744b44d1041b0b71e7014fb66fa646176b2b356bc45a59248a4bf08be4f690ed1449db4653513c323e342564efe3d94c29117792158530b4e59cee6 phonon-4.8.1.tar.xz"