aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-amqp
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-10-20 23:58:24 +0300
committerAndy Postnikov <apostnikov@gmail.com>2018-10-21 00:29:26 +0300
commit87de79fa2a249213136e19b80b3ae974037518eb (patch)
treed217a9c88af749fb7609ae833406bcdada7073ed /community/php7-pecl-amqp
parent3c6cf472f2791fc533ed94dc6c88a5f6497220ac (diff)
community/php7-pecl-amqp: renamed from php7-amqp, modernize
Diffstat (limited to 'community/php7-pecl-amqp')
-rw-r--r--community/php7-pecl-amqp/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/php7-pecl-amqp/APKBUILD b/community/php7-pecl-amqp/APKBUILD
new file mode 100644
index 00000000000..f5b96f947ce
--- /dev/null
+++ b/community/php7-pecl-amqp/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-pecl-amqp
+_pkgreal=amqp
+pkgver=1.9.3
+pkgrel=2
+pkgdesc="PHP extension to communicate with any AMQP spec 0-9-1 compatible server - PECL"
+url="https://pecl.php.net/package/amqp"
+arch="all"
+license="PHP"
+depends="php7-common"
+makedepends="php7-dev autoconf rabbitmq-c-dev re2c"
+source="$pkgname-$pkgver.tgz::https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+options="!check" # it seems that tests need running AMQP server
+builddir="$srcdir/$_pkgreal-$pkgver"
+provides="php7-amqp=$pkgver-r$pkgrel" # for backward compatibility
+replaces="php7-amqp" # for backward compatibility
+
+build() {
+ cd "$builddir"
+
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+package() {
+ local confdir="$pkgdir/etc/php7/conf.d"
+ cd "$builddir"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ mkdir -p "$confdir"
+ echo "extension=$_pkgreal.so" > "$confdir"/40_$_pkgreal.ini
+}
+
+sha512sums="d4731ed5dc760a01621889e8518b5d1258a8335f701d241c453fd553924d83507a0a918b9733e249955fa11b43a1bdacf65c1f1cb55b8ed3c5b661277f5798b9 php7-pecl-amqp-1.9.3.tgz"