aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-xdebug
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-10-20 21:16:35 +0300
committerAndy Postnikov <apostnikov@gmail.com>2018-10-20 22:18:59 +0300
commitbd0243a0cf64380e80aaa5ce3b1814aed156c69a (patch)
tree1c5a08ee3453068143af922603f982ed097f3783 /community/php7-pecl-xdebug
parentf04acc55a9c33d3d8786192a7d3308694c8da12a (diff)
community/php7-pecl-xdebug: renamed from php7-xdebug, modernize
Diffstat (limited to 'community/php7-pecl-xdebug')
-rw-r--r--community/php7-pecl-xdebug/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/php7-pecl-xdebug/APKBUILD b/community/php7-pecl-xdebug/APKBUILD
new file mode 100644
index 00000000000..55a0679f6d5
--- /dev/null
+++ b/community/php7-pecl-xdebug/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Andy Postnikov <apostnikov@gmail.com>
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Andy Postnikov <apostnikov@gmail.com>
+pkgname=php7-pecl-xdebug
+_pkgname=xdebug
+pkgver=2.6.1
+pkgrel=1
+pkgdesc="PHP extension that provides functions for function traces and profiling - PECL"
+url="https://pecl.php.net/package/xdebug"
+arch="all"
+license="PHP"
+depends="php7-common"
+makedepends="php7-dev autoconf re2c"
+source="$pkgname-$pkgver.tgz::https://pecl.php.net/get/$_pkgname-$pkgver.tgz"
+options="!check" # upstream does not provide tests yet
+builddir="$srcdir/$_pkgname-$pkgver"
+provides="php7-xdebug=$pkgver-r$pkgrel" # for backward compatibility
+replaces="php7-xdebug" # for backward compatibility
+
+build() {
+ cd "$builddir"
+
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+package() {
+ local confdir="$pkgdir/etc/php7/conf.d"
+ cd "$builddir"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ mkdir -p "$confdir"
+ cat > "$confdir"/$_pkgname.ini <<-EOF
+ ; Uncomment to enable this extension.
+ ;zend_extension=$_pkgname.so
+ EOF
+}
+
+sha512sums="31f26e592b3888d7cc74c6a7c51e0cc1151cf8a32100dda78098fb5b3e307cf8d0445b97247986c75b303a787f89b3937bc042dc52f19ca995753a6843bbd80b php7-pecl-xdebug-2.6.1.tgz"