aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-yaml/APKBUILD
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2020-04-25 03:12:13 +0300
committerAndy Postnikov <apostnikov@gmail.com>2020-04-25 05:32:28 +0300
commitebd5cbf762717a605f5264fc3ce99bade92cf254 (patch)
treea3d3afbe75d6314bf807d318b074ffd4e2a4f86c /community/php7-pecl-yaml/APKBUILD
parentdf2317c3f2662ae2c2c1f6d729a6c1ad3aec23bf (diff)
community/php7-pecl-yaml: upgrade to 2.1.0
Diffstat (limited to 'community/php7-pecl-yaml/APKBUILD')
-rw-r--r--community/php7-pecl-yaml/APKBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/community/php7-pecl-yaml/APKBUILD b/community/php7-pecl-yaml/APKBUILD
index 6e79c945962..573fc757955 100644
--- a/community/php7-pecl-yaml/APKBUILD
+++ b/community/php7-pecl-yaml/APKBUILD
@@ -1,22 +1,22 @@
# Maintainer: Renoir Boulanger <hello@renoirboulanger.com>
pkgname=php7-pecl-yaml
_pkgreal=yaml
-pkgver=2.0.4
-pkgrel=1
+pkgver=2.1.0
+pkgrel=0
pkgdesc="YAML syntax bindings for PHP"
url="https://pecl.php.net/package/yaml"
arch="all"
license="MIT"
-makedepends="php7-dev autoconf yaml-dev"
+makedepends="php7-dev autoconf re2c yaml-dev"
depends="php7-common"
# Set source file explicitly, otherwise extracted archive directory breaks the build.
-source="$pkgname-$pkgver.tgz::https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+source="$pkgname-$pkgver.tgz::https://pecl.php.net/get/$_pkgreal-$pkgver.tgz
+ 32bit.patch"
builddir="$srcdir/$_pkgreal-$pkgver"
provides="php7-yaml=$pkgver-r$pkgrel" # for backward compatibility
replaces="php7-yaml" # for backward compatibility
build() {
- cd "$builddir"
phpize7
./configure \
--prefix=/usr \
@@ -26,15 +26,14 @@ build() {
# Thanks to @TBK for https://github.com/php/pecl-file_formats-yaml/pull/29
check() {
- cd "$builddir"
make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
}
package() {
- cd "$builddir"
make INSTALL_ROOT="$pkgdir" install
install -d $pkgdir/etc/php7/conf.d
echo "extension=$_pkgreal.so" > $pkgdir/etc/php7/conf.d/70_$_pkgreal.ini
}
-sha512sums="138e5b4566800fc7d624baf71bc585d6d432755046e598ae9f4099fa565727e04d79bb171289a53eb9e5daa416ffee1b0fb4967c84976ac6cd6fc01b0a05fbae php7-pecl-yaml-2.0.4.tgz"
+sha512sums="3731ca2b84e80599d7fae4f58efdd11e9920c672ea6e62ff6b0d57d721d3f6f12ca86efe88f63c324d4ad2b73d6947a21f6e5a47263538ca0d5e822b8fc7b8bd php7-pecl-yaml-2.1.0.tgz
+96cbb76f747ee75f73b048b3f612eddc9a4904bb212028c9f38030e0cb365e31d9048c4a180fb2d1258c5da38f8e37e76a843b66549d40407011c5d53eeb3c5a 32bit.patch"