aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-30 00:18:14 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-02 01:04:51 +0200
commitc997492ce9d4070c926df759df94f4bc566a1bbc (patch)
tree5430d00829e8608524e08fb710b69691706a9adc /community/php7/APKBUILD
parent12c3073e53487779b136d6db3e090d9d46a82dfc (diff)
community/php7: upgrade to 7.1.4
This patch is based on https://github.com/alpinelinux/aports/pull/1305, but includes only changes relevant to the upgrade (I'll apply the rest separately).
Diffstat (limited to 'community/php7/APKBUILD')
-rw-r--r--community/php7/APKBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index 8590d2a8895..65692a2d3dd 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
pkgname=php7
_pkgreal=php
-pkgver=7.0.18
-pkgrel=1
+pkgver=7.1.4
+pkgrel=0
pkgdesc="The PHP language runtime engine - 7th branch"
url="http://www.php.net/"
arch="all"
@@ -30,11 +30,9 @@ source="http://php.net/distributions/$_pkgreal-$pkgver.tar.bz2
$pkgname-fpm.logrotate
$pkgname-module.conf
install-pear.patch
- tidy-buffio.patch
includedir.patch
fix-asm-constraints-in-aarch64-multiply-macro.patch
- pid_log.patch
- libressl.patch
+ php7-fpm-version-suffix.patch
"
builddir="$srcdir/$_pkgreal-$pkgver"
@@ -54,7 +52,7 @@ for _ext in $_exts; do
done
subpackages="$subpackages $pkgname-common::noarch"
-_apiver="20151012"
+_apiver="20160303"
prepare() {
cd "$builddir"
@@ -145,7 +143,6 @@ _build() {
--enable-wddx=shared \
--enable-zip=shared --with-libzip=shared \
$@ || return 1
- sed -ri "s/^(EXTRA_LDFLAGS[ ]*\=.*)/\1 -lpthread/" Makefile # see #183 (from main/php)
make || return 1
}
@@ -347,13 +344,11 @@ _package_ext() {
> "$subpkgdir"/etc/$pkgname/conf.d/${elo}_${extname}.ini
}
-sha512sums="eccd9d68578373bb27aeb2d3b6d1a202e428bd622daaa069e1d526a81f2a406bf9d1852d73fbf9dc7a4488f514ab50f4a6c87ee6b4ac172c6f2b7f214b1dea56 php-7.0.18.tar.bz2
+sha512sums="a1dd5ffd756176e6ba600dd850510033d0d6f07aff314de69fec0c42437e6a006449e3f4f98679146a2f2645caa65ea351e31a8e1da7c14cc5260856ad40eaff php-7.1.4.tar.bz2
1c708de82d1086f272f484faf6cf6d087af7c31750cc2550b0b94ed723961b363f28a947b015b2dfc0765caea185a75f5d2c2f2b099c948b65c290924f606e4f php7-fpm.initd
cacce7bf789467ff40647b7319e3760c6c587218720538516e8d400baa75651f72165c4e28056cd0c1dc89efecb4d00d0d7823bed80b29136262c825ce816691 php7-fpm.logrotate
fbf9a1572d37370ec0d126502e1d066e045a992484d8fc4f1e2ede330134c1a15f4029f29fa4daebd48eed78b045dc051ced69fbf1f11efc7ad81d884a639a99 php7-module.conf
f1177cbf6b1f44402f421c3d317aab1a2a40d0b1209c11519c1158df337c8945f3a313d689c939768584f3e4edbe52e8bd6103fb6777462326a9d94e8ab1f505 install-pear.patch
-6894c9cba7752a3406e774d9efc0e058c37433493c1c20101e9563bf247c112157a67e306b06b9517b0422eca521f543d637a6cbd2cea7639e43f13d773b3d2b tidy-buffio.patch
199aecdbd3b4035aabf5379c215f82412d3c98b79a1ee186944e7fe1f0ed6f40789ea30e2355149491de6be34fc66c5e486e2a79a7e41ab2ae18706ef3ffe79b includedir.patch
d93d3fc015580cf5f75c6cbca4cd980e054b61e1068495da81a7e61f1af2c9ae14f09964c04928ad338142de78e4844aed885b1ad1865282072999fb045c8ad7 fix-asm-constraints-in-aarch64-multiply-macro.patch
-82231c7b27b4d044272857dc713674884715ed8e36e54be06faa5d2a949ba4bca597628958a9c5683ec51c36e05a00f6be811c7e95112b0314c98528f584a8d6 pid_log.patch
-d04d7cccae789ebf607f4fd107c26b580752353c8636c6c509123285063d274f3fb4aa28e0b31677515435e41a234e9990d45ceb70756ac7f7aa4cb9b11faecb libressl.patch"
+a4c35446745ab0ac806de801f0651fc5d2c98cf60063c3c2d3963a84f1c71ef78e09b7650c08e7231be0fdb93c0c255de38894d7f0e4f4c5a190d17f1a6bc476 php7-fpm-version-suffix.patch"