aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7/APKBUILD
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2020-02-20 22:07:20 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-02-22 18:35:48 -0300
commitda479a7adc9366cbc8f662b0412d7feea79fd9d6 (patch)
tree98e653a6644dbd866928ba0a42fe19ebab72804d /community/php7/APKBUILD
parentf3e9b41c04ff46cfede4c2390638e4358ab32356 (diff)
community/php7: add lmdb support for php7-dba
Diffstat (limited to 'community/php7/APKBUILD')
-rw-r--r--community/php7/APKBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index 8ed2e9f0c08..3e0b4b3d164 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -27,7 +27,7 @@
pkgname=php7
_pkgreal=php
pkgver=7.3.15
-pkgrel=1
+pkgrel=2
_apiver=20180731
_suffix=${pkgname#php}
# Is this package the default (latest) PHP version?
@@ -67,6 +67,7 @@ makedepends="
libical-dev
libjpeg-turbo-dev
libpng-dev
+ lmdb-dev
openssl-dev
libsodium-dev
libwebp-dev
@@ -236,8 +237,6 @@ esac
# - CVE-2018-10549
prepare() {
- cd "$builddir"
-
default_prepare
update_config_sub
@@ -302,6 +301,7 @@ _build() {
--with-db4 \
--with-dbmaker=shared \
--with-gdbm \
+ --with-lmdb \
--enable-dom=shared \
--with-enchant=shared \
--enable-exif=shared \
@@ -380,8 +380,6 @@ _build() {
}
build() {
- cd "$builddir"
-
# phpdbg
_build --enable-phpdbg \
--enable-phpdbg-webhelper \
@@ -403,8 +401,6 @@ build() {
}
check() {
- cd "$builddir"
-
# PHP is so stupid that it's not able to resolve dependencies
# between extensions and load them in correct order, so we must
# help it...
@@ -425,14 +421,12 @@ check() {
NO_INTERACTION=1 REPORT_EXIT_STATUS=1 \
SKIP_SLOW_TESTS=1 SKIP_ONLINE_TESTS=1 TEST_TIMEOUT=10 \
TZ= LANG= LC_ALL= \
- make test || [ "$allow_fail" = yes ] || return 1
+ make test || [ "$allow_fail" = yes ]
echo 'NOTE: We have skipped quite a lot tests, see disabled-tests.list.'
}
package() {
- cd "$builddir"
-
make -j1 INSTALL_ROOT="$pkgdir" install
install -Dm644 php.ini-production "$pkgdir"/etc/$pkgname/php.ini