aboutsummaryrefslogtreecommitdiffstats
path: root/community/php8
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2021-08-20 16:50:28 +0300
committerAndy Postnikov <apostnikov@gmail.com>2021-08-20 16:50:28 +0300
commit0f145ab32937f3f12d7c76ba6ec0e573c4731331 (patch)
treed6b0bd5d3a789c95c93b4aa22d40f80723a3ab5e /community/php8
parent4d16dadcae5a9144345bf8e67fbd82aa6261633b (diff)
community/php8: build cgi instead of cli
Diffstat (limited to 'community/php8')
-rw-r--r--community/php8/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/php8/APKBUILD b/community/php8/APKBUILD
index f096328ea75..1134bc85968 100644
--- a/community/php8/APKBUILD
+++ b/community/php8/APKBUILD
@@ -261,6 +261,7 @@ _build() {
--with-imap=shared \
--with-imap-ssl \
--enable-intl=shared \
+ --with-kerberos \
--with-ldap=shared \
--with-ldap-sasl \
--with-libedit \
@@ -271,7 +272,6 @@ _build() {
--enable-mysqlnd=shared \
--enable-opcache=shared \
--with-openssl=shared \
- --with-kerberos \
--with-system-ciphers \
--with-password-argon2 \
--enable-pcntl=shared \
@@ -316,7 +316,7 @@ build() {
# build apache2 SAPIs first
# because not fixed https://bugs.php.net/bug.php?id=52419
_build --disable-phpdbg \
- --disable-cgi \
+ --disable-cli \
--with-apxs2
mv libs/libphp.so sapi/apache2handler/mod_php$_suffix.so