aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-desktop
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-02-11 13:16:17 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-02-11 13:44:36 -0300
commit7489710b31bec3e4c5cca6f15477efcbbe1dacfd (patch)
treed9eb99cd7726060ede8dc2702d901b9128ef0674 /community/plasma-desktop
parent4ea9b126a7c0dceba731dcbddbaa7d505140204a (diff)
community/plasma: upgrade to 5.18.0
Diffstat (limited to 'community/plasma-desktop')
-rw-r--r--community/plasma-desktop/APKBUILD24
-rw-r--r--community/plasma-desktop/revert-fix-jagginess-for-activities-list-icons.patch33
2 files changed, 7 insertions, 50 deletions
diff --git a/community/plasma-desktop/APKBUILD b/community/plasma-desktop/APKBUILD
index a8e90cf5f77..30e5bd35d46 100644
--- a/community/plasma-desktop/APKBUILD
+++ b/community/plasma-desktop/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-desktop
-pkgver=5.17.5
-pkgrel=1
+pkgver=5.18.0
+pkgrel=0
pkgdesc="KDE Plasma Desktop"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
url='https://www.kde.org/workspaces/plasmadesktop/'
@@ -47,24 +47,16 @@ depends_dev="
"
makedepends="$depends_dev extra-cmake-modules kdoctools-dev"
checkdepends="xvfb-run iso-codes"
-source="https://download.kde.org/stable/plasma/$pkgver/plasma-desktop-$pkgver.tar.xz
- revert-fix-jagginess-for-activities-list-icons.patch"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-desktop-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang knetattach"
options="!check" # Requires running dbus
-prepare() {
- default_prepare
-
- mkdir "$builddir"/build
-}
-
build() {
- cd "$builddir"/build
- cmake "$builddir" \
+ cmake -B "$builddir"/build \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
- make
+ make -C build
}
check() {
@@ -73,8 +65,7 @@ check() {
}
package() {
- cd "$builddir"/build
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" make -C build install
rm "$pkgdir"/usr/bin/knetattach
rm "$pkgdir"/usr/share/applications/org.kde.knetattach.desktop
@@ -87,5 +78,4 @@ knetattach() {
cd "$builddir"/build/knetattach
DESTDIR="$subpkgdir" make install
}
-sha512sums="c910be6bf63091f14f190e8fbfbd0039aa175d30f7a6870dbd99ffc3ff49a0f77e63e2d3fc9319dab1c650b15108cdaefee470eddab1213afe8d3a149ac64dd4 plasma-desktop-5.17.5.tar.xz
-e4c84c37788bdc0f98f2b6c45ca497a3f8eac5b948ddf034c40ee12af0d1ac88d3ebf64dd146936f4f0f1b295c7fa7f3cd2854f85e2ec3dd546a8ccc716f3bdd revert-fix-jagginess-for-activities-list-icons.patch"
+sha512sums="863516751f4f37193ad5a96713fa9c7eb8d346e3bbe33dc43dcb83fa18955456dc875ddc3e2db990e7f3a017e394a69790e3dc21e13e8fc0c5d6841591c8fb4e plasma-desktop-5.18.0.tar.xz"
diff --git a/community/plasma-desktop/revert-fix-jagginess-for-activities-list-icons.patch b/community/plasma-desktop/revert-fix-jagginess-for-activities-list-icons.patch
deleted file mode 100644
index cc3232ccfad..00000000000
--- a/community/plasma-desktop/revert-fix-jagginess-for-activities-list-icons.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 1db4d07bb78858da7676720d13ee7c4f3bd8e6e0 Mon Sep 17 00:00:00 2001
-From: Nate Graham <nate@kde.org>
-Date: Sun, 12 Jan 2020 08:39:29 -0700
-Subject: Revert "[KCMs/Activities] Fix jagginess for activities list icons on
- high DPI systems"
-
-This reverts commit 567f71714faac305947573e307f486a9960cf1d1.
-
-The commit in question was pushed without review and should not have
-been. It worked fine for me in local testing but somehow was broken
-anyway. Sorry. :(
-
-BUG: 416158
----
- kcms/activities/qml/activitiesTab/ActivitiesView.qml | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/kcms/activities/qml/activitiesTab/ActivitiesView.qml b/kcms/activities/qml/activitiesTab/ActivitiesView.qml
-index 531ef9f..aac13a2 100644
---- a/kcms/activities/qml/activitiesTab/ActivitiesView.qml
-+++ b/kcms/activities/qml/activitiesTab/ActivitiesView.qml
-@@ -52,8 +52,6 @@ ColumnLayout {
- height: Kirigami.Units.iconSizes.medium
- width: height
- source: model.icon
-- sourceSize.width: model.icon.width
-- sourceSize.height: model.icon.height
- }
-
- QQC2.Label {
---
-cgit v1.1
-