aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-pa/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-18 16:13:36 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-20 12:24:41 -0300
commitb3553abc60cd45495f8a252a5a06ca25c6749952 (patch)
tree89dc4e90e78d313a485ccb0fd7264c132d9d4381 /community/plasma-pa/APKBUILD
parent9a177212eb91a159b575312d0824a790ad551adf (diff)
community/plasma: upgrade to 5.17.0
Diffstat (limited to 'community/plasma-pa/APKBUILD')
-rw-r--r--community/plasma-pa/APKBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/community/plasma-pa/APKBUILD b/community/plasma-pa/APKBUILD
index 3c2f49e0636..b2213f64705 100644
--- a/community/plasma-pa/APKBUILD
+++ b/community/plasma-pa/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-pa
-pkgver=5.16.5
+pkgver=5.17.0
pkgrel=0
pkgdesc="Plasma applet for audio volume management using PulseAudio"
arch="all !ppc64le !s390x" # Limited by plasma-workspace -> libksysguard -> qt5-qtwebengine
@@ -9,11 +9,18 @@ url="https://www.kde.org/workspaces/plasmadesktop/"
license="LGPL-2.1-only OR LGPL-3.0-only AND GPL-2.0-only"
depends="pulseaudio kirigami2"
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev kcoreaddons-dev kdeclarative-dev kdoctools-dev kglobalaccel-dev knotifications-dev ki18n-dev plasma-workspace-dev pulseaudio-dev libcanberra-dev"
-source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-pa-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -22,10 +29,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="393cc05b8999b10213fd608863d16f14c3d38fe8d82b01a1869bb37a4c8ce4d023deaac11a12a087f79bea5ffca9ff4e3dd846fd2ba195df8513e9ea8d3a8618 plasma-pa-5.16.5.tar.xz"
+sha512sums="6f2cb3c6872a4169b665d2fb04c6d39c7a5c6c847ff5276d043c99de4cc0939ab4db89acb951bdc9eb8c031d59815199f9272f911fd20ea51f0993c542e0a824 plasma-pa-5.17.0.tar.xz"