aboutsummaryrefslogtreecommitdiffstats
path: root/community/pluma
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-14 15:12:37 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-09 15:20:36 +0000
commit191c045740fa24c17afaa8f2265749c52bfff098 (patch)
tree05315a1be5f9fdafec929d42bf025e0362320af1 /community/pluma
parente846da6788accadd1f3a13e649d15726c310b432 (diff)
community/pluma: modernize abuild
Diffstat (limited to 'community/pluma')
-rw-r--r--community/pluma/APKBUILD26
1 files changed, 6 insertions, 20 deletions
diff --git a/community/pluma/APKBUILD b/community/pluma/APKBUILD
index ae7562076f1..2d20f668103 100644
--- a/community/pluma/APKBUILD
+++ b/community/pluma/APKBUILD
@@ -7,41 +7,27 @@ pkgdesc="A small and lightweight UTF-8 text editor for the MATE"
url="https://github.com/mate-desktop/pluma"
arch="all"
license="GPLv2"
-depends=""
-depends_dev=""
makedepends="$depends_dev intltool enchant-dev iso-codes-dev gtk+3.0-dev
mate-desktop-dev gtksourceview-dev dconf-dev libsm-dev itstool
libxml2-utils fortify-headers libpeas-dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz
0001-fix-accessperms-in-tests.patch"
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--sysconfdir=/etc \
- --prefix=/usr \
- || return 1
- make || return 1
+ --prefix=/usr
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="${pkgdir}" install || return 1
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" install
}
sha512sums="a38e50019cdb2523aa5e727a4bebaf9dc2e4a9d520ae9eb3272867b85d5d89b8fbc2789f4a7e80c9566dcd133ea90da77cd295537c27900dad74c1095aed37f6 pluma-1.18.1.tar.xz