aboutsummaryrefslogtreecommitdiffstats
path: root/community/postgresql-plpgsql_check/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-19 02:34:11 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-19 02:34:11 +0200
commit8e3086bca786035aea2325c381e6df64aec643c3 (patch)
tree9f8d8a66017eb952a7d5a940287c79055a5811c8 /community/postgresql-plpgsql_check/APKBUILD
parent091a6d804005b543a41a5808b931aa4314a67951 (diff)
community/postgresql-plpgsql_check: move from testing
Diffstat (limited to 'community/postgresql-plpgsql_check/APKBUILD')
-rw-r--r--community/postgresql-plpgsql_check/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/postgresql-plpgsql_check/APKBUILD b/community/postgresql-plpgsql_check/APKBUILD
new file mode 100644
index 00000000000..d816f5988aa
--- /dev/null
+++ b/community/postgresql-plpgsql_check/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=postgresql-plpgsql_check
+_pkgname=plpgsql_check
+pkgver=1.2.1
+pkgrel=0
+pkgdesc="Additional tools for plpgsql functions validation"
+url="https://github.com/okbob/plpgsql_check"
+arch="all"
+license="BSD"
+depends="postgresql"
+makedepends="postgresql-dev"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/okbob/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+options="!check" # XXX: installcheck requires running PostgreSQL
+
+build() {
+ cd "$builddir"
+ make USE_PGXS=1 all
+}
+
+package() {
+ cd "$builddir"
+ make USE_PGXS=1 DESTDIR="$pkgdir" install
+}
+
+sha512sums="bf41a9e89b387d172780264707a5e33d30ffecda76ed29d7077c477f3c70a554a86e41a8fb8f9accb773e6e1d4f0e5744b6d012db00cf2e20ded2b350ec5121d plpgsql_check-1.2.1.tar.gz"