aboutsummaryrefslogtreecommitdiffstats
path: root/community/pulseaudio-qt/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-12-09 15:31:49 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-10 09:09:08 +0100
commit553f8e45f0c6a7582a2942f8c1d73478224af787 (patch)
treef1e56e426b9392b756b7a2d14b48b573a1e7e129 /community/pulseaudio-qt/APKBUILD
parent0a79f2481d80cac9cea03b0a9991de2cf2338bf0 (diff)
community/pulseaudio-qt: move from testing
Diffstat (limited to 'community/pulseaudio-qt/APKBUILD')
-rw-r--r--community/pulseaudio-qt/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/pulseaudio-qt/APKBUILD b/community/pulseaudio-qt/APKBUILD
new file mode 100644
index 00000000000..6c656d118c2
--- /dev/null
+++ b/community/pulseaudio-qt/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=pulseaudio-qt
+pkgver=1.1.0
+pkgrel=0
+arch="all"
+url="https://cgit.kde.org/pulseaudio-qt.git/"
+pkgdesc="Pulseaudio bindings for Qt"
+license="LGPL-2.1-only OR LGPL-3.0-only"
+depends_dev="qt5-qtbase-dev pulseaudio-dev glib-dev"
+makedepends="$depends_dev extra-cmake-modules doxygen graphviz qt5-qttools-dev"
+checkdepends="qt5-qtdeclarative-dev"
+source="https://download.kde.org/stable/pulseaudio-qt/pulseaudio-qt-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc"
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"/build
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="8d143a6c3dd0f1fd824fa1f0233435243cf551739e5ddf2579a86bc1c25c479f42d56a5cb7ef886513118ef5f37106062e49c0955b4ab356682c310d391ff11c pulseaudio-qt-1.1.0.tar.xz"