aboutsummaryrefslogtreecommitdiffstats
path: root/community/purpose
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-14 19:46:37 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-17 12:13:50 -0300
commit49afd00440e7a1725cb4701a2ff879e994a55389 (patch)
tree915f5c810b7027a5a99e9ed935ab50f9d8dde87e /community/purpose
parente58bd7992d0d7b657f02561eb4c255bdfe6751d6 (diff)
community/kde-frameworks: upgrade to 5.63.0
Diffstat (limited to 'community/purpose')
-rw-r--r--community/purpose/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/purpose/APKBUILD b/community/purpose/APKBUILD
index 2c310669937..79a0f7ec593 100644
--- a/community/purpose/APKBUILD
+++ b/community/purpose/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=purpose
-pkgver=5.62.0
+pkgver=5.63.0
pkgrel=0
pkgdesc="Framework for providing abstractions to get the developer's purposes fulfilled"
arch="all"
@@ -14,8 +14,15 @@ checkdepends="xvfb-run"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/purpose-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -24,11 +31,13 @@ build() {
}
check() {
+ cd "$builddir"/build
# This is 1 of 2 tests
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E 'menutest'
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="fb77ced4fa2045d21d9ab746aa92a88e35b44b16f29ab5cfa4a4c52b9bdda1b6d79c4422b61e97dd67897bd1145afd27e533d37d08cedc1f704eb095fc7d7dc0 purpose-5.62.0.tar.xz"
+sha512sums="cfba4fc1ab7ed45e91964fcb3d10bfbf315b342494c3b3cd16bf5ab5b01c2ad69be6e28eaa0fd92134e753a53c5560fae752c9aaf9b906567edf2777d2efc1d4 purpose-5.63.0.tar.xz"