aboutsummaryrefslogtreecommitdiffstats
path: root/community/pv
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-08-17 22:45:10 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-08-17 22:45:10 +0200
commit695b657c574087f5620bb9c41e4cab3dd835542d (patch)
treeddb4711543e7d377716a44e416e4abccca28e71f /community/pv
parentc6ab94ec8f08ab8fd7e7943b6785935d63e9beeb (diff)
community/pv: move from testing
Diffstat (limited to 'community/pv')
-rw-r--r--community/pv/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/pv/APKBUILD b/community/pv/APKBUILD
new file mode 100644
index 00000000000..da1f9ee9b64
--- /dev/null
+++ b/community/pv/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=pv
+pkgver=1.6.0
+pkgrel=0
+pkgdesc="CLI tool for monitoring the progress of data through a pipeline"
+url="http://www.ivarch.com/programs/pv.shtml"
+arch="all"
+license="Artistic-2.0"
+depends=""
+makedepends="$depends_dev"
+subpackages="$pkgname-doc"
+source="http://www.ivarch.com/programs/sources/pv-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="e163d8963c595b2032666724bc509bcc pv-1.6.0.tar.bz2"
+sha256sums="0ece824e0da27b384d11d1de371f20cafac465e038041adab57fcf4b5036ef8d pv-1.6.0.tar.bz2"
+sha512sums="bd405901812ca50b910adbcf1d2c540dc0b8612f03687866734a79cfa5b5b8100024c18a1d1413c6613e1f2085989cbb77907da89bec7eda37cdeaa7597129d5 pv-1.6.0.tar.bz2"