aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-cheetah
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2017-12-11 23:07:46 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-12-13 10:30:25 +0000
commit39c7b1be0efd7ee113cbddd400ca9e0e5394a064 (patch)
treed4be8eba8642fe542deccb36a80b62abc2f7feef /community/py-cheetah
parent3c4c7c7357466243ab8be337f2de590184cca90c (diff)
community/py-cheetah: move from testing
Diffstat (limited to 'community/py-cheetah')
-rw-r--r--community/py-cheetah/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/community/py-cheetah/APKBUILD b/community/py-cheetah/APKBUILD
new file mode 100644
index 00000000000..fc1ec6416de
--- /dev/null
+++ b/community/py-cheetah/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Matt Dainty <matt+alpine@bodgit-n-scarper.com>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=py-cheetah
+_pkgreal=${pkgname#py-}
+_pkgname=Cheetah3
+pkgver=3.0.0
+pkgrel=0
+pkgdesc="Cheetah is a template engine and code generation tool"
+url="http://www.cheetahtemplate.org/"
+arch="all"
+license="MIT"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py3-$_pkgreal:_py3 py2-$_pkgreal:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="861356cbb0cc5c698eecce6b0393cd16658748f372c731d3ed9bfa1741c5bdb209d350561bafba8fc3cf96c0d1a7f00e9caa1d7367e228d50710ba803a47383c Cheetah3-3.0.0.tar.gz"