aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-dicttoxml
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 12:31:22 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 14:21:34 +0000
commit6d0175348d85ed0105c843e1fd56766c3c499809 (patch)
treea0a6c34322c835b05144346ef70e56900ebaf11a /community/py-dicttoxml
parentd85dbba6ae6f3931a541970089e79dadeec81574 (diff)
community/py-dicttoxml: moved from testing, added python3 support and py2/py3 subpackages
Diffstat (limited to 'community/py-dicttoxml')
-rw-r--r--community/py-dicttoxml/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/py-dicttoxml/APKBUILD b/community/py-dicttoxml/APKBUILD
new file mode 100644
index 00000000000..aec9ff4a98b
--- /dev/null
+++ b/community/py-dicttoxml/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-dicttoxml
+_pkgname=dicttoxml
+pkgver=1.7.4
+pkgrel=0
+pkgdesc="Converts a Python dictionary or other native data type into a valid XML string"
+url="https://github.com/quandyfactory/dicttoxml"
+arch="noarch"
+license="GPL2"
+depends=""
+makedepends="python2-dev python3-dev"
+install=""
+subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc - $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ _py python2
+ replaces="$pkgname"
+}
+
+_py3() {
+ _py python3
+}
+
+
+md5sums="ec5643a048cf32dad3c28db236b923e4 dicttoxml-1.7.4.tar.gz"
+sha256sums="ea44cc4ec6c0f85098c57a431a1ee891b3549347b07b7414c8a24611ecf37e45 dicttoxml-1.7.4.tar.gz"
+sha512sums="91abcf2b9b248717618e9fc1c8694e881b9deaa16438dd4674f94a22b4aabfdab3b13f95c3d44a60577d49eca82fb268f59b33d1312cf5388bdaf949a2865cbf dicttoxml-1.7.4.tar.gz"