aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-eyed3
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-07-16 17:26:15 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-16 20:50:38 +0000
commit37caadb3b9d29d0bfab3f7a8df354552fd9e1e7e (patch)
treead89f11a8af6297ce3aa804608c8ab6a2f47532e /community/py-eyed3
parent9bc40b2ff1fbd0006a40519f5744bbaad81d74fa (diff)
community/py-eyed3: upgrade to python3
Diffstat (limited to 'community/py-eyed3')
-rw-r--r--community/py-eyed3/APKBUILD14
-rw-r--r--community/py-eyed3/no-pathlib.patch17
2 files changed, 25 insertions, 6 deletions
diff --git a/community/py-eyed3/APKBUILD b/community/py-eyed3/APKBUILD
index 60d0bb9e497..da1b5a1f2e2 100644
--- a/community/py-eyed3/APKBUILD
+++ b/community/py-eyed3/APKBUILD
@@ -7,22 +7,24 @@ pkgdesc="ID3 tag editor in Python"
url="http://eyed3.nicfit.net/"
arch="noarch"
license="GPL-3.0-or-later"
-depends="python2"
+depends="python3 py3-magic py3-six"
depends_dev=""
-makedepends="python2-dev py-setuptools"
+makedepends="py3-setuptools python3-dev"
install=""
subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ no-pathlib.patch"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$builddir"
- python2 setup.py build
+ python3 setup.py build
}
package() {
cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="b8ab690e54385355c6a80fb2aba97d9e1b4b7b713d6365f2aad4080acdead7fe517086b0cb0a1dc675096ce163dc86bf4cdee56a5df37633690eb2d221807603 eyeD3-0.8.7.tar.gz"
+sha512sums="b8ab690e54385355c6a80fb2aba97d9e1b4b7b713d6365f2aad4080acdead7fe517086b0cb0a1dc675096ce163dc86bf4cdee56a5df37633690eb2d221807603 eyeD3-0.8.7.tar.gz
+2fa54a0e0a35bbea5d5d48646dbea7a3de96f2152e9bea503caa077d3342055caf0e59f0b0c2aa1e03950b62ea9b1c594fcf5466ea5aae9fadb7ad76944d4d1c no-pathlib.patch"
diff --git a/community/py-eyed3/no-pathlib.patch b/community/py-eyed3/no-pathlib.patch
new file mode 100644
index 00000000000..756c052e54f
--- /dev/null
+++ b/community/py-eyed3/no-pathlib.patch
@@ -0,0 +1,17 @@
+--- a/requirements/requirements.yml
++++ b/requirements/requirements.yml
+@@ -1,6 +1,5 @@
+ main:
+ - six
+- - pathlib # Remove with python 2.7 and 3.3
+ - python-magic
+
+ extra_display-plugin:
+@@ -18,7 +17,6 @@
+ - factory-boy
+
+ test_py33:
+- - pathlib
+ - mock
+
+ dev: