aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-flask-login
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-01-08 14:01:01 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2019-01-08 20:10:49 +0000
commit1d4ee2d0090345148f7c41f236a44265788854ac (patch)
tree3c103dbac2bbd509796d5290f98f30cd32c73692 /community/py-flask-login
parent81566d8d0bc4d71d674500031ad389966ff46bac (diff)
community/py-flask-login: move from testing
Diffstat (limited to 'community/py-flask-login')
-rw-r--r--community/py-flask-login/APKBUILD70
1 files changed, 70 insertions, 0 deletions
diff --git a/community/py-flask-login/APKBUILD b/community/py-flask-login/APKBUILD
new file mode 100644
index 00000000000..d17cb2da370
--- /dev/null
+++ b/community/py-flask-login/APKBUILD
@@ -0,0 +1,70 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=py-flask-login
+_pkgname=Flask-Login
+pkgver=0.4.1
+pkgrel=0
+pkgdesc="Flask user session management"
+url="https://pypi.python.org/pypi/Flask-Login"
+arch="noarch"
+license="BSD"
+makedepends="
+ py-setuptools
+ py2-flask
+ py2-nose
+ py3-flask
+ py3-nose
+ python2-dev
+ python3-dev
+"
+subpackages="py2-flask-login:py2 py3-flask-login:py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+prepare() {
+ cp -r "$builddir" "$builddir"-py2
+ cp -r "$builddir" "$builddir"-py3
+}
+
+build() {
+ cd "$builddir"-py2
+ python2 setup.py build
+ cd "$builddir"-py3
+ python3 setup.py build
+}
+
+check() {
+ py2ver=$(python2 --version 2>&1 | cut -d' ' -f2 | cut -d. -f1-2)
+ py3ver=$(python3 --version 2>&1 | cut -d' ' -f2 | cut -d. -f1-2)
+ cd "$builddir"-py2
+ nosetests-$py2ver
+ cd "$builddir"-py3
+ nosetests-$py3ver
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ python="$1"
+ pkgdesc="$pkgdesc ${python#python}"
+ depends="$depends $python py${python#python}-flask"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+py2() {
+ cd "$builddir"-py2
+ _py python2
+}
+
+py3() {
+ cd "$builddir"-py3
+ _py python3
+}
+
+sha512sums="e57c80647e5504adb302490e6497165952a45c4bb211836bbd8bc2932ee19073bf7a8635ea4928ab83b9ae630617d3309089e62eaf07442ab094e9b1559b151f Flask-Login-0.4.1.tar.gz"