aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-greenlet
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2018-10-26 13:41:05 +0200
committerAndy Postnikov <apostnikov@gmail.com>2018-10-26 15:11:26 +0300
commit709480b8991cd0205d461f9d6e083cac44000537 (patch)
tree32187752cba1df4436d9a9b209184992f9f3e173 /community/py-greenlet
parentf44ddea6a89cebe8633101ac89bca43982f9833d (diff)
community/py-greenlet: upgrade to 0.4.15
Diffstat (limited to 'community/py-greenlet')
-rw-r--r--community/py-greenlet/APKBUILD8
-rw-r--r--community/py-greenlet/gcc-4.8-bugfix.patch16
-rw-r--r--community/py-greenlet/ppc64le_clobbering.patch21
3 files changed, 3 insertions, 42 deletions
diff --git a/community/py-greenlet/APKBUILD b/community/py-greenlet/APKBUILD
index ef0fd9258aa..69770bab8a2 100644
--- a/community/py-greenlet/APKBUILD
+++ b/community/py-greenlet/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Elizabeth Jennifer Myers <elizabeth@sporksirc.net>
pkgname=py-greenlet
_pkgname=greenlet
-pkgver=0.4.13
+pkgver=0.4.15
pkgrel=0
pkgdesc="Lightweight in-process concurrent programming"
url="https://pypi.python.org/pypi/greenlet"
@@ -11,8 +11,7 @@ license="MIT"
depends=""
makedepends="python2-dev py-setuptools python3-dev"
subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- ppc64le_clobbering.patch"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -51,5 +50,4 @@ _py3() {
_py python3
}
-sha512sums="625aaa8875b408442139191e1a63eca71c668675229907335f5caee623487aba5305c1d53b51e1764ad982b8edd07d04f984e08a75318a0a5672805667917a61 greenlet-0.4.13.tar.gz
-fdadaefaa69a07c1926a000c70ed58b92e2103942b7031310575e3b2feefa15d56d2f9df72db3cab583b97d1f6607df5e09bd85bc3be284a0de18d2d1ffbe869 ppc64le_clobbering.patch"
+sha512sums="a3b7856aadc988fe153f5cf62552dd6219358f35ee2ca136e5eb5c9871cb7545986753af299e6b3e95877e9aa564559e95c548785f78e680766630b047a1ec89 greenlet-0.4.15.tar.gz"
diff --git a/community/py-greenlet/gcc-4.8-bugfix.patch b/community/py-greenlet/gcc-4.8-bugfix.patch
deleted file mode 100644
index 1526f3eb186..00000000000
--- a/community/py-greenlet/gcc-4.8-bugfix.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- greenlet-0.4.0.orig/setup.py
-+++ greenlet-0.4.0/setup.py
-@@ -2,12 +2,7 @@
-
- import sys, os, glob, platform
-
--# workaround segfaults on openbsd and RHEL 3 / CentOS 3 . see
--# https://bitbucket.org/ambroff/greenlet/issue/11/segfault-on-openbsd-i386
--# https://github.com/python-greenlet/greenlet/issues/4
--if ((sys.platform == "openbsd4" and os.uname()[-1] == "i386")
-- or ("-with-redhat-3." in platform.platform() and platform.machine() == 'i686')):
-- os.environ["CFLAGS"] = ("%s %s" % (os.environ.get("CFLAGS", ""), "-Os")).lstrip()
-+os.environ['CFLAGS'] = '-O0'
-
- try:
- if not (sys.modules.get("setuptools")
diff --git a/community/py-greenlet/ppc64le_clobbering.patch b/community/py-greenlet/ppc64le_clobbering.patch
deleted file mode 100644
index c4d237f4f61..00000000000
--- a/community/py-greenlet/ppc64le_clobbering.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Author: Breno Leitao <breno.leitao@gmail.com>
-Date: Mon Apr 10 23:22:01 2017 +0000
-
- Do not clobber r31 if you are not omitting frame pointer
-
- R31 is the register that is defined in the ABI v2 as the frame pointer.
- It should not be clobbered unless we omit the frame pointer.
-
- Signed-off-by: Breno Leitao <breno.leitao@gmail.com>
-
---- greenlet-0.4.12/platform/switch_ppc64_linux.h.old 2017-04-10 19:14:26.808511638 +0000
-+++ greenlet-0.4.12/platform/switch_ppc64_linux.h 2017-04-10 19:14:34.556511856 +0000
-@@ -57,7 +57,7 @@
- #endif
-
- #define REGS_TO_SAVE "r2", "r14", "r15", "r16", "r17", "r18", "r19", "r20", \
-- "r21", "r22", "r23", "r24", "r25", "r26", "r27", "r28", "r29", "r31", \
-+ "r21", "r22", "r23", "r24", "r25", "r26", "r27", "r28", "r29", \
- "fr14", "fr15", "fr16", "fr17", "fr18", "fr19", "fr20", "fr21", \
- "fr22", "fr23", "fr24", "fr25", "fr26", "fr27", "fr28", "fr29", \
- "fr30", "fr31", \