aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-greenlet
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2018-10-26 13:39:22 +0200
committerAndy Postnikov <apostnikov@gmail.com>2018-10-26 15:11:26 +0300
commitf44ddea6a89cebe8633101ac89bca43982f9833d (patch)
tree3ac53c50c9d2a07d0b77a1bb241c2a85ab0a839d /community/py-greenlet
parente60e535e608526b765cc842022ac2f910e78961c (diff)
community/py-greenlet: modernize and add check
Diffstat (limited to 'community/py-greenlet')
-rw-r--r--community/py-greenlet/APKBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/community/py-greenlet/APKBUILD b/community/py-greenlet/APKBUILD
index 21c8b3d37dd..ef0fd9258aa 100644
--- a/community/py-greenlet/APKBUILD
+++ b/community/py-greenlet/APKBUILD
@@ -19,14 +19,20 @@ builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
export CFLAGS="-O0" CPPFLAGS="-O0" CXXFLAGS="-O0"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
}
package() {
mkdir -p "$pkgdir"
}
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
+}
+
_py() {
local python=$1
pkgdesc="$pkgdesc - $python"