aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-ndg_httpsclient
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-12-09 13:36:50 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2015-12-09 13:36:50 +0100
commit15d1ec2d5e5d36fc7e78d96f34d9c3583bf56dc2 (patch)
treedf4c2d69dbcda1059524061bd66259f1cd4734ca /community/py-ndg_httpsclient
parenta66174411f51be92d56e3937f790e1fca75c91d5 (diff)
move letsencrypt deps to community
Diffstat (limited to 'community/py-ndg_httpsclient')
-rw-r--r--community/py-ndg_httpsclient/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/py-ndg_httpsclient/APKBUILD b/community/py-ndg_httpsclient/APKBUILD
new file mode 100644
index 00000000000..a917c4d5c84
--- /dev/null
+++ b/community/py-ndg_httpsclient/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-ndg_httpsclient
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="HTTPS client implementation for httplib and urllib2 based on PyOpenSSL"
+url="https://github.com/cedadev/ndg_httpsclient"
+arch="noarch"
+license="BSD"
+depends="py-openssl py-asn1"
+depends_dev=""
+makedepends="$depends_dev py-setuptools"
+install=""
+subpackages=""
+source="ndg_httpsclient-$pkgver.tar.gz::https://github.com/cedadev/ndg_httpsclient/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/ndg_httpsclient-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="b7577b1eaa2a25915c7a963e0d2f80a5 ndg_httpsclient-0.4.0.tar.gz"
+sha256sums="d8954102b851dc775b12535d6623d41ee0849146ea8b8a2d937a5c12ca8ba19d ndg_httpsclient-0.4.0.tar.gz"
+sha512sums="4ff71ce7a475e2828e4836f77cbbcc6c9f99c6d5b0e4510b805be0e50f95a337665d73a54b355dc3ae51d752857dd886ba0c9c1dcc7d7041ebbed6df8842cd88 ndg_httpsclient-0.4.0.tar.gz"