aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-pathtools/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-05-19 19:11:18 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-24 07:43:15 +0000
commitc7267903b7c514aaa665e957d3f30fe5a5d75c02 (patch)
tree8bdb074193149bd3ac1ccb8db5141383af778c4d /community/py-pathtools/APKBUILD
parent5a2707876c4c0f22a0f8ffcf70dfaee9b93926fa (diff)
community/py-pathtools: modernize abuild
Diffstat (limited to 'community/py-pathtools/APKBUILD')
-rw-r--r--community/py-pathtools/APKBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/community/py-pathtools/APKBUILD b/community/py-pathtools/APKBUILD
index 42a756e7a96..76835aad7c7 100644
--- a/community/py-pathtools/APKBUILD
+++ b/community/py-pathtools/APKBUILD
@@ -3,21 +3,21 @@
pkgname=py-pathtools
_pkgname=pathtools
pkgver=0.1.2
-pkgrel=2
-pkgdesc="Path utilities for Python"
+pkgrel=3
+pkgdesc="Path utilities"
url="https://github.com/gorakhargosh/pathtools"
arch="noarch"
license="MIT"
depends=""
makedepends="py-setuptools python2-dev python3-dev"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
}
package() {
@@ -43,6 +43,4 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-md5sums="9a1af5c605768ea5804b03b734ff0f82 py-pathtools-0.1.2.tar.gz"
-sha256sums="7c35c5421a39bb82e58018febd90e3b6e5db34c5443aaaf742b3f33d4655f1c0 py-pathtools-0.1.2.tar.gz"
-sha512sums="e014cb17f3d61ce7979e36663f94a44d4f1116c35e3d2ec8c4ac207a81935dde246495ed06597e6edade1509f384b9e5729a97ffd3eec31b1d1c4a8372d1dfd7 py-pathtools-0.1.2.tar.gz"
+sha512sums="e014cb17f3d61ce7979e36663f94a44d4f1116c35e3d2ec8c4ac207a81935dde246495ed06597e6edade1509f384b9e5729a97ffd3eec31b1d1c4a8372d1dfd7 pathtools-0.1.2.tar.gz"