aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-prettytable
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-07-27 01:21:05 +0300
committerprspkt <prspkt@protonmail.com>2019-07-27 01:24:49 +0300
commit04fc7ecd20db9802b7a23ea8fe00e7f758ea0418 (patch)
tree809df090adfec8e3928add923ecd8898c6ae4ae9 /community/py-prettytable
parent501922b37a915818edf7162bca0c5a38e1059861 (diff)
community/py-prettytable: drop python2
Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'community/py-prettytable')
-rw-r--r--community/py-prettytable/APKBUILD52
1 files changed, 0 insertions, 52 deletions
diff --git a/community/py-prettytable/APKBUILD b/community/py-prettytable/APKBUILD
deleted file mode 100644
index 9ed269d0e90..00000000000
--- a/community/py-prettytable/APKBUILD
+++ /dev/null
@@ -1,52 +0,0 @@
-# Contributor: Matt Dainty <matt+alpine@bodgit-n-scarper.com>
-# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
-pkgname=py-prettytable
-_pkgname=prettytable
-pkgver=0.7.2
-pkgrel=2
-pkgdesc="A simple Python library for easily displaying tabular data in a visually appealing ASCII table format"
-url="http://code.google.com/p/prettytable/"
-arch="noarch"
-license="BSD"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
-source="https://files.pythonhosted.org/packages/source/P/PrettyTable/$_pkgname-$pkgver.tar.gz"
-
-builddir="$srcdir/$_pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-check() {
- cd "$builddir"
- python2 setup.py test
- python3 setup.py test
-}
-
-package() {
- cd "$builddir"
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-sha512sums="84611b9ad11bd428cdb00795e0a9baff44d027331b73ed1742596acda8acc8aca3df4276fa2f2ca2289f10b2989b3c86556de70bca6a9773b15cd80c54c33117 prettytable-0.7.2.tar.gz"