aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-zope-event/APKBUILD
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-09-26 01:28:40 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-09-26 01:28:40 +0000
commit7d15a912d89b510be972375b2102aa6ed460ac74 (patch)
tree6216564ce6b656f6414cb82fc6e61fb6f82e65dd /community/py-zope-event/APKBUILD
parent5cffe94345dbd5eaab122745ca27bfc77d8a2262 (diff)
community/py-zope-event: upgrade to 4.3.0 and modernize
Diffstat (limited to 'community/py-zope-event/APKBUILD')
-rw-r--r--community/py-zope-event/APKBUILD31
1 files changed, 8 insertions, 23 deletions
diff --git a/community/py-zope-event/APKBUILD b/community/py-zope-event/APKBUILD
index f7e4ffb03c2..1067f03d2a2 100644
--- a/community/py-zope-event/APKBUILD
+++ b/community/py-zope-event/APKBUILD
@@ -1,40 +1,25 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=py-zope-event
-pkgver=4.2.0
+pkgver=4.3.0
pkgrel=0
pkgdesc="Event publishing / dispatch, used by Zope Component Architecture"
url="https://github.com/zopefoundation/zope.event"
arch="noarch"
license="ZPL"
-depends=""
-depends_dev=""
-makedepends="$depends_dev py-setuptools"
-install=""
-subpackages=""
+makedepends="py-setuptools"
source="zope.event-$pkgver.tar.gz::https://github.com/zopefoundation/zope.event/archive/$pkgver.tar.gz"
-_builddir="$srcdir"/zope.event-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/zope.event-$pkgver
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="c8d79db625d5411c4777b7ca87b718a6 zope.event-4.2.0.tar.gz"
-sha256sums="20b0a3abe0dadfac853f9922287e598cce8f73b9dcfd68c10aaf6f897d0dfd7f zope.event-4.2.0.tar.gz"
-sha512sums="d2bf195c6e74c4a043b4013ad6c1d39e104470a383096b42837197c1639ae18ebdc25e06c2f09a44c0014f046a2f7cc72584820efbed66c9e45cd94bb2b1c81e zope.event-4.2.0.tar.gz"
+sha512sums="7c42074023f56395156ef7bb120b00972dca8dfa2c80dd0387cb6f58b22380e34f8a2bf7b2fe717941cbcf1997e1aaea9f500f124fceb1c664c90e6c55150ffa zope.event-4.3.0.tar.gz"