aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-aiohttp1
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-06-01 11:56:09 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-06-02 09:56:00 +0000
commitcbd163ecd102f0780fa729692e343ead03be773a (patch)
treebb0b0e55451e74d89c4700e2e652351f5a4e95d0 /community/py3-aiohttp1
parent69ea2d4119e68a133d013d2608a71007d32636c6 (diff)
community/py3-aiohttp1: new aport. Needed to make GNS3 works again
Diffstat (limited to 'community/py3-aiohttp1')
-rw-r--r--community/py3-aiohttp1/APKBUILD33
-rw-r--r--community/py3-aiohttp1/dropped-requirements.patch13
2 files changed, 46 insertions, 0 deletions
diff --git a/community/py3-aiohttp1/APKBUILD b/community/py3-aiohttp1/APKBUILD
new file mode 100644
index 00000000000..b761555763d
--- /dev/null
+++ b/community/py3-aiohttp1/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-aiohttp1
+_pkgname=aiohttp
+pkgver=1.3.5
+pkgrel=0
+pkgdesc="HTTP client/server for asyncio - 1.x version"
+url="http://pypi.python.org/pypi/aiohttp"
+arch="all"
+license="ASL 2.0"
+depends="python3 py3-async-timeout py3-chardet py3-multidict py3-yarl !py3-aiohttp"
+makedepends="python3-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/aio-libs/aiohttp/archive/$pkgver.tar.gz
+ dropped-requirements.patch"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --root="$pkgdir" --optimize=1
+}
+
+sha512sums="5315d8c77d6886486274fb8f2e3f10cb8f97050b097560e5b1cfd51b4d094dc45281cad894ea51079c6b7054f396d46b89f4c471835d1b058dcc90faaf01eaa4 py3-aiohttp1-1.3.5.tar.gz
+29e8172c2038b2900e82de0eb5b47f3265b144e5ec470a1868d3453a1be2e5295c5363bac258120f49ed785d2c82ae14f185292a28847a40b44d7b071b8dd083 dropped-requirements.patch"
diff --git a/community/py3-aiohttp1/dropped-requirements.patch b/community/py3-aiohttp1/dropped-requirements.patch
new file mode 100644
index 00000000000..a51360143a5
--- /dev/null
+++ b/community/py3-aiohttp1/dropped-requirements.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index d6e0461..01eda33 100644
+--- a/setup.py
++++ b/setup.py
+@@ -55,7 +55,7 @@ with codecs.open(os.path.join(os.path.abspath(os.path.dirname(
+
+
+ install_requires = ['chardet', 'multidict>=2.1.4',
+- 'async_timeout>=1.1.0', 'yarl>=0.9.8,<0.10']
++ 'async_timeout>=1.1.0', 'yarl>=0.9.8']
+
+ if sys.version_info < (3, 4, 2):
+ raise RuntimeError("aiohttp requires Python 3.4.2+")