aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-astroid/APKBUILD
diff options
context:
space:
mode:
authorLuca Weiss <luca@z3ntu.xyz>2021-05-08 22:39:41 +0200
committerLeo <thinkabit.ukim@gmail.com>2021-05-08 22:14:37 +0000
commitc08aebb05b21a8840aa0ab4b1fcca9c6d9fd2588 (patch)
tree0098ba921a6c62f2da584c10be9972d737e356f1 /community/py3-astroid/APKBUILD
parenta4c90c422ee19c3028bc0ac4f3b074d0a6818b10 (diff)
community/py3-astroid: upgrade to 2.5.6
Also remove unused six dependency
Diffstat (limited to 'community/py3-astroid/APKBUILD')
-rw-r--r--community/py3-astroid/APKBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/community/py3-astroid/APKBUILD b/community/py3-astroid/APKBUILD
index 77b6f348676..d06a598d8a1 100644
--- a/community/py3-astroid/APKBUILD
+++ b/community/py3-astroid/APKBUILD
@@ -1,38 +1,32 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-astroid
-pkgver=2.5.3
+pkgver=2.5.6
pkgrel=0
pkgdesc="A new abstract syntax tree from Python's ast"
url="https://www.astroid.org"
arch="noarch"
license="LGPL-2.1-or-later"
-depends="py3-lazy-object-proxy py3-six py3-typed-ast py3-wrapt"
+depends="py3-lazy-object-proxy py3-typed-ast py3-wrapt"
replaces="py-logilab-astng"
makedepends="py3-setuptools"
checkdepends="py3-pytest py3-pytest-runner"
source="https://files.pythonhosted.org/packages/source/a/astroid/astroid-$pkgver.tar.gz"
builddir="$srcdir"/astroid-$pkgver
-
-prepare() {
- default_prepare
- # Remove pinned version restrictions
- sed -e 's/six~=[0-9.*]*/six/' \
- -e 's/wrapt~=[0-9.*]*/wrapt/' \
- -e 's/lazy_object_proxy==[0-9.*]*/lazy_object_proxy/' \
- -i astroid/__pkginfo__.py
-}
+options="!check" # PyPI archive doesn't contain tests anymore
build() {
python3 setup.py build
}
check() {
- python3 -m pytest -v
+ pytest
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="dbf480e86023f7d093386cc68b259d5b721717638927a893b3ade0a397b212f5f24a17c753b705cf499b47e12ab255d51126b41b5af167d5c3018f5aade1abcb astroid-2.5.3.tar.gz"
+sha512sums="
+f622e0a1d76a2b85ff95751c663a2d057164ee1ad3543483e12910444fd447428cb57fe79c3484fe6c99f6c762eaf2933f1dec0bed1531116d157c1d45560e22 astroid-2.5.6.tar.gz
+"