aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-icu/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:48:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-02 01:43:47 +0000
commitaad2afe051973fa7fd6f4f9b83703c09445ff17c (patch)
tree4266144bb0c3984f784b0dd910d33fa98a72c353 /community/py3-icu/APKBUILD
parentaad758e364da9a69d0d519b619cc6eb2c7d150f8 (diff)
community/py3-*: move from main/ and modernize
Diffstat (limited to 'community/py3-icu/APKBUILD')
-rw-r--r--community/py3-icu/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-icu/APKBUILD b/community/py3-icu/APKBUILD
new file mode 100644
index 00000000000..4726a556f72
--- /dev/null
+++ b/community/py3-icu/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py3-icu
+_pkgname=PyICU
+pkgver=2.4.3
+pkgrel=1
+pkgdesc="Python3 binding for ICU"
+url="https://pypi.org/project/PyICU/"
+arch="all"
+license="MIT"
+makedepends="py3-setuptools python3-dev icu-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces="py-icu" # Backwards compatibility
+provides="py-icu=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py check
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="77b81b0e9a17972696967ebc0421d05c1119a43c7e853f8d939390dddefa4a2a35dd316e08c10c10a283472bb64738016e47c5f45c7c6191d9dba296057740a0 PyICU-2.4.3.tar.gz"