aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-multidict
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-06-22 13:07:18 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-06-22 13:07:18 +0000
commitfe766f7e20814be5141035aeecf9ba7a70eb7cd4 (patch)
tree0392f3b5be6f0d78731d4c6a1438224c679dc9eb /community/py3-multidict
parent2a9bbafcb970753f903e62fc6e2d1b28671696f2 (diff)
community/py3-multidict: added check() function
Diffstat (limited to 'community/py3-multidict')
-rw-r--r--community/py3-multidict/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/community/py3-multidict/APKBUILD b/community/py3-multidict/APKBUILD
index eea531b72b0..a6060f962fb 100644
--- a/community/py3-multidict/APKBUILD
+++ b/community/py3-multidict/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-multidict
_pkgname=multidict
pkgver=2.1.6
-pkgrel=0
+pkgrel=1
pkgdesc="multidict implementation"
url="https://github.com/aio-libs/multidict/"
arch="all"
@@ -14,14 +14,19 @@ subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
build() {
cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
}
package() {
cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="70e6727b28d9f97ece00c46c81f6d3095befa57f09de2a400b53e8b9676561de89ffe57de4810a25a9264941678f5f139aeb25489611e09b10259aed19b616f3 py3-multidict-2.1.6.tar.gz"