aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-openzwave
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2018-12-21 15:04:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-12-21 18:05:14 +0000
commitad59d7c6c409f7a10dbf70d2b3210233cc9be8b4 (patch)
tree84c8150506a0eaeba6d5d954c634bc6af76b2e40 /community/py3-openzwave
parent5c29a89c72bc0e63c3ff52799ac3edbaa25752ad (diff)
community/py3-openzwave: disable Werror to fix snprintf build error
Diffstat (limited to 'community/py3-openzwave')
-rw-r--r--community/py3-openzwave/APKBUILD8
-rw-r--r--community/py3-openzwave/disable-Werror.patch11
2 files changed, 16 insertions, 3 deletions
diff --git a/community/py3-openzwave/APKBUILD b/community/py3-openzwave/APKBUILD
index 69c0cb79026..ab867227f90 100644
--- a/community/py3-openzwave/APKBUILD
+++ b/community/py3-openzwave/APKBUILD
@@ -3,7 +3,7 @@
_name=python-openzwave
pkgname=py3-openzwave
pkgver=0.3.2
-pkgrel=0
+pkgrel=1
pkgdesc="Python wrapper for openzwave"
url="http://www.openzwave.com/"
arch="all"
@@ -12,7 +12,8 @@ depends=" $pkgname-lib $pkgname-api $pkgname-manager"
makedepends="python3-dev linux-headers eudev-dev coreutils"
install=""
subpackages="$pkgname-lib $pkgname-api::noarch $pkgname-manager::noarch"
-source="https://github.com/OpenZWave/python-openzwave/raw/master/archives/${_name}-${pkgver}.tgz"
+source="https://github.com/OpenZWave/python-openzwave/raw/master/archives/${_name}-${pkgver}.tgz
+ disable-Werror.patch"
builddir="$srcdir/python-openzwave-$pkgver"
@@ -57,4 +58,5 @@ manager() {
}
-sha512sums="f495c2e41a67f715dbf0e312ee13d59ab6c907403dacb12d48c2becbb433ab458a53f3d634e21373e1aa0141ab71e418ec15ebd29f9d4506261700bcfadcbc79 python-openzwave-0.3.2.tgz"
+sha512sums="f495c2e41a67f715dbf0e312ee13d59ab6c907403dacb12d48c2becbb433ab458a53f3d634e21373e1aa0141ab71e418ec15ebd29f9d4506261700bcfadcbc79 python-openzwave-0.3.2.tgz
+5ac0755abf43cff49583305abb2fcaa963a5f926b6e6109dbe75724d6c7dd301621e7fd2e6eb16b45e258ef9ea1686d774b3a32a96ec256c31d703314952bedf disable-Werror.patch"
diff --git a/community/py3-openzwave/disable-Werror.patch b/community/py3-openzwave/disable-Werror.patch
new file mode 100644
index 00000000000..77197315eb0
--- /dev/null
+++ b/community/py3-openzwave/disable-Werror.patch
@@ -0,0 +1,11 @@
+--- a/openzwave/cpp/build/Makefile
++++ b/openzwave/cpp/build/Makefile
+@@ -15,7 +15,7 @@
+ # what flags we will use for compiling in debug mode
+ DEBUG_CFLAGS := -Wall -Wno-unknown-pragmas -Wno-inline -Wno-format -Werror -Wno-error=sequence-point -Wno-sequence-point -ggdb -DDEBUG -fPIC -DSYSCONFDIR="\"$(PREFIX)/etc/openzwave/\""
+ # what flags we will use for compiling in release mode
+-RELEASE_CFLAGS := -Wall -Wno-unknown-pragmas -Werror -Wno-format -Wno-error=sequence-point -Wno-sequence-point -O3 -DNDEBUG -fPIC -DSYSCONFDIR="\"$(PREFIX)/etc/openzwave/\""
++RELEASE_CFLAGS := -Wall -Wno-unknown-pragmas -Wno-format -Wno-error=sequence-point -Wno-sequence-point -O3 -DNDEBUG -fPIC -DSYSCONFDIR="\"$(PREFIX)/etc/openzwave/\""
+ #what flags we will use for linking in debug mode
+ DEBUG_LDFLAGS := -g
+