aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pickleshare/APKBUILD
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-03-17 21:56:49 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-04 06:04:24 +0000
commita40a44c9fa78243bae9e503f238d1636085e0afb (patch)
tree457f236255125349fe8e8815ce75622cb76784b0 /community/py3-pickleshare/APKBUILD
parentb111e6a766b9d1fa6a48bd564f4fab99db4533be (diff)
testing/py3-pickleshare: move to community
Diffstat (limited to 'community/py3-pickleshare/APKBUILD')
-rw-r--r--community/py3-pickleshare/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/py3-pickleshare/APKBUILD b/community/py3-pickleshare/APKBUILD
new file mode 100644
index 00000000000..15793a76746
--- /dev/null
+++ b/community/py3-pickleshare/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=py3-pickleshare
+pkgver=0.7.5
+pkgrel=0
+pkgdesc="File system based database that uses python pickles"
+url="https://github.com/pickleshare/pickleshare"
+arch="noarch"
+license="MIT"
+options="!check" # No test suite
+makedepends="python3-dev py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/pickleshare/pickleshare/archive/$pkgver.tar.gz"
+builddir="$srcdir/${pkgname#py3-}-$pkgver/"
+replace="py-pickleshare"
+provides="py-pickleshare"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="eb5b1a12d9a78032601fe0a4aa036a0a2d2e007a79ec1d39aa7e28d33465b6e7346f3edf5a4de33030b41f3acfd2cca6cc7ab508d33fc79bd0f11178729905e8 py3-pickleshare-0.7.5.tar.gz"