aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pylast/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:48:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-02 01:43:47 +0000
commitaad2afe051973fa7fd6f4f9b83703c09445ff17c (patch)
tree4266144bb0c3984f784b0dd910d33fa98a72c353 /community/py3-pylast/APKBUILD
parentaad758e364da9a69d0d519b619cc6eb2c7d150f8 (diff)
community/py3-*: move from main/ and modernize
Diffstat (limited to 'community/py3-pylast/APKBUILD')
-rw-r--r--community/py3-pylast/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-pylast/APKBUILD b/community/py3-pylast/APKBUILD
new file mode 100644
index 00000000000..2ddb3bb7762
--- /dev/null
+++ b/community/py3-pylast/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-pylast
+pkgver=3.2.1
+pkgrel=0
+pkgdesc="A Python interface to the last.fm API"
+url="https://github.com/pylast/pylast"
+arch="noarch"
+license="Apache"
+replaces="py-pylast"
+# Requires unpackaged flaky
+options="!check"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/p/pylast/pylast-$pkgver.tar.gz"
+builddir="$srcdir"/pylast-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+
+sha512sums="982324745c92adaaed6be94c2d947fbc4a3d716e56cbd84c797ba85b4160a169e19ccb6b735a6904665b346aa41cef851e2756b9620055f4e441aae3fb245372 pylast-3.2.1.tar.gz"