aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pyrsistent
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-04-24 10:37:34 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-24 10:37:34 +0000
commit3b978a80fe81e423b3e35cb20fa52e392b7f27c6 (patch)
treea5c1c56cfcc79df6d7648a2a894747251db10a65 /community/py3-pyrsistent
parent149db244654c394292247b532bc287abc7219de5 (diff)
community/py3-pyrsistent: move from testing
This is a run-time dependency for py-jsonschema, which is already in community.
Diffstat (limited to 'community/py3-pyrsistent')
-rw-r--r--community/py3-pyrsistent/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-pyrsistent/APKBUILD b/community/py3-pyrsistent/APKBUILD
new file mode 100644
index 00000000000..b5da20e56b8
--- /dev/null
+++ b/community/py3-pyrsistent/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-pyrsistent
+pkgver=0.14.11
+pkgrel=1
+pkgdesc="Persistent/Functional/Immutable data structures"
+url="https://github.com/tobgu/pyrsistent"
+arch="all"
+license="MIT"
+depends="py3-six"
+makedepends="py3-setuptools python3-dev"
+checkdepends="py3-hypothesis py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tobgu/pyrsistent/archive/v${pkgver}.tar.gz"
+builddir="$srcdir/pyrsistent-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="8bfea52e15b1921ff9880a6d795cbbcdbee818ef5b95a2807e28269eba8ff578e07c39615e48eb47e867dd6f2bca5d395b7ae99ecd27424edaf6cbe6097b2e5d py3-pyrsistent-0.14.11.tar.gz"