aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pysocks/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-28 21:20:21 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-28 21:54:17 -0300
commit23a5864542874c091217b05f9906f9732d456a83 (patch)
treeda3bb593f464865c7083f7b0dd85b9adb77c95e4 /community/py3-pysocks/APKBUILD
parentb4fad14a66095518989f1d175b02ec4d62578974 (diff)
community/py3-pysocks: upgrade to 1.7.0
Diffstat (limited to 'community/py3-pysocks/APKBUILD')
-rw-r--r--community/py3-pysocks/APKBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/community/py3-pysocks/APKBUILD b/community/py3-pysocks/APKBUILD
index 02cb30838c3..29d1f193970 100644
--- a/community/py3-pysocks/APKBUILD
+++ b/community/py3-pysocks/APKBUILD
@@ -1,30 +1,27 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer:
pkgname=py3-pysocks
-pkgver=1.6.8
-pkgrel=1
+pkgver=1.7.0
+pkgrel=0
pkgdesc="Python Socks module"
url="https://github.com/Anorov/PySocks"
arch="noarch"
-license="BSD"
+license="BSD-3-Clause"
depends="python3"
-makedepends="python3-dev py3-setuptools"
+makedepends="py3-setuptools"
source="https://pypi.io/packages/source/P/PySocks/PySocks-$pkgver.tar.gz"
builddir="$srcdir/PySocks-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 setup.py check
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="9b544cf11464142a5f347cd5688b48422249363a425ccf3887117152f2f1969713674c4bba714242432ae85f3d62e03edeb9cb7b73ebd225ed3b47b3da6896d5 PySocks-1.6.8.tar.gz"
+sha512sums="cc08ecbf65b59b6c4d4a24e01490dba19d93f2deb2860a49c4fc5679a9ceaba1860f05faaf8e299cf195e184a844f11989595e5046b07e2b30f9f3c682950e52 PySocks-1.7.0.tar.gz"