aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-qt5
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-11-22 03:00:48 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-11-22 03:00:48 +0000
commit69ac7474ac479b112dbd8d68888690b28b4d068a (patch)
tree6ce77b7d79342166a933c387872225b9b93b2e21 /community/py3-qt5
parent32fd46f5053009f69559fe75dc5b6a5d2b641958 (diff)
community/py3-qt5: upgrade to 5.9.1
Diffstat (limited to 'community/py3-qt5')
-rw-r--r--community/py3-qt5/APKBUILD40
1 files changed, 23 insertions, 17 deletions
diff --git a/community/py3-qt5/APKBUILD b/community/py3-qt5/APKBUILD
index 22d48b2c407..b43567d8404 100644
--- a/community/py3-qt5/APKBUILD
+++ b/community/py3-qt5/APKBUILD
@@ -2,37 +2,43 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-qt5
_pkgname=PyQt5
-pkgver=5.8.2
+pkgver=5.9.1
pkgrel=0
pkgdesc="A set of Python 3 bindings for the Qt toolkit"
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
arch="all"
license="GPL2+"
depends="py3-sip"
-makedepends="python3-dev py-dbus-dev qt5-qtbase-dev py3-sip-dev libx11-dev qt5-qtsvg-dev"
+makedepends="python3-dev py-dbus-dev py3-sip-dev
+ qt5-qtbase-dev libx11-dev qt5-qtsvg-dev qt5-websockets-dev"
source="https://sourceforge.net/projects/pyqt/files/$_pkgname/PyQt-$pkgver/${_pkgname}_gpl-$pkgver.zip"
builddir="${srcdir}/${_pkgname}_gpl-${pkgver}"
-check() {
- cd "$builddir"
- make check
+prepare() {
+ default_prepare
+ cd "$builddir"
+ sed -i '/target_config.dbus_inc_dirs = \[\]/d' configure.py
}
build() {
- cd "$builddir"
- python3 configure.py \
- --confirm-license \
- --qmake /usr/lib/qt5/bin/qmake \
- -v /usr/share/sip \
- --qsci-api
- # Thanks Gerardo for the rpath fix
- find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
- make
+ cd "$builddir"
+ python3 configure.py \
+ --confirm-license \
+ --qmake /usr/lib/qt5/bin/qmake \
+ -v /usr/share/sip \
+ --qsci-api
+ find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package(){
- cd "$builddir"
- make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
}
-sha512sums="b50369fe4f3d315886dd2158c7e42f8bb281d5f74eb3c66429266280bb8e4fca5138c678c50283f61b1f30c3cda021508921197281f3188df0457cea828b1c18 PyQt5_gpl-5.8.2.zip"
+sha512sums="e33a7856b73cb02c5ac307729abcbffdb4badf5ec4bfccd02cf70786c9f9639b154968931b35d75e426953dec024be3472297ec6a1efb26a7e8f79f26e9f89d7 PyQt5_gpl-5.9.1.zip"