aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-watchdog
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-04-26 20:02:26 +0300
committerprspkt <prspkt@protonmail.com>2019-04-26 22:20:21 +0300
commiteda7bdfc7823ca2234d910a32d068057c5a5c5d1 (patch)
tree9a1b3ed44a5e1582474647970f38bd982113de83 /community/py3-watchdog
parent12a1037cb0575f356c6621f970283d4b4e65a45b (diff)
community/py-watchdog: upgrade to python3
Diffstat (limited to 'community/py3-watchdog')
-rw-r--r--community/py3-watchdog/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/py3-watchdog/APKBUILD b/community/py3-watchdog/APKBUILD
new file mode 100644
index 00000000000..243099b8dbe
--- /dev/null
+++ b/community/py3-watchdog/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-watchdog
+pkgver=0.9.0
+pkgrel=0
+pkgdesc="Python API and shell utilities to monitor file system events."
+url="https://github.com/gorakhargosh/watchdog"
+arch="noarch"
+license="Apache-2.0"
+replaces="py-watchdog" # for backwards compatibility
+provides="py-watchdog=$pkgver-r$pkgrel" # for backwards compatibility
+depends="py3-pathtools py3-yaml py3-argh"
+depends_dev=""
+makedepends="py3-setuptools"
+install=""
+subpackages=""
+source="watchdog-$pkgver.tar.gz::https://github.com/gorakhargosh/watchdog/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/watchdog-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+sha512sums="97fca2642209150a611d931d6f2049a9941a3494a6c566bc18eaa45a8fc2fbd02c712b37a85cc1375eeb65715706ba6b8ecf781b99951721988c318f81eff7c6 watchdog-0.9.0.tar.gz"