aboutsummaryrefslogtreecommitdiffstats
path: root/community/pytest-xdist/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-04-05 09:04:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-17 11:45:41 +0000
commit2705587a9d7e8daf54b39fb90f457a1e6d84710f (patch)
tree52c01d685c169f263826b168700e8df1f058cadd /community/pytest-xdist/APKBUILD
parent4ed85d5c68909ae211488ef41157c16555a30cb2 (diff)
community/pytest-xdist: upgrade to 1.28.0
Diffstat (limited to 'community/pytest-xdist/APKBUILD')
-rw-r--r--community/pytest-xdist/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/community/pytest-xdist/APKBUILD b/community/pytest-xdist/APKBUILD
index d2d2b3fd1b2..e91f13a6cba 100644
--- a/community/pytest-xdist/APKBUILD
+++ b/community/pytest-xdist/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Dmitry Romanenko <dmitry@romanenko.in>
# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
pkgname=pytest-xdist
-pkgver=1.26.1
+pkgver=1.28.0
pkgrel=0
pkgdesc="pytest xdist plugin for distributed testing and loop-on-failing modes"
url="https://github.com/pytest-dev/pytest-xdist"
@@ -25,7 +25,8 @@ check() {
mkdir -p tmp_py3
python3 setup.py install --root="$builddir/tmp_py3" --optimize=1
- PYTHONPATH="$builddir/tmp_py3/usr/lib/python3.6/site-packages:$PYTHONPATH" python3 -m pytest
+ local _py3ver=$(python3 -c 'import sys; print("{}.{}".format(sys.version_info.major, sys.version_info.minor))')
+ PYTHONPATH="$builddir/tmp_py3/usr/lib/python$_py3ver/site-packages:$PYTHONPATH" python3 -m pytest
}
package() {
@@ -51,4 +52,4 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="c98be542447b6715410ef458961e1a9edcf692b60d119a61d596289f4e7c8899f23d6c7a34e2507dda792cfae8645730da6714b113e75ab64214bdba44666750 pytest-xdist-1.26.1.tar.gz"
+sha512sums="89b8885103a944ae72535de40028db052f76631ade6f969489d3dc3a1a61a3233df6655d0905d9f5253f23740a15aea824b460c680e79c16f275b31cb2abd6ad pytest-xdist-1.28.0.tar.gz"