aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtlocation
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-05-01 11:21:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-01 11:40:27 +0000
commit344a93722265afabe64db1717946a34e7e1abb67 (patch)
treea167c20f232602e8b6f01dea68335d9d8d0756af /community/qt5-qtlocation
parent64cfe4271b99b346203b1f218796067d9a131aa5 (diff)
community/qt5-qt[various]: move from testing
Diffstat (limited to 'community/qt5-qtlocation')
-rw-r--r--community/qt5-qtlocation/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/qt5-qtlocation/APKBUILD b/community/qt5-qtlocation/APKBUILD
new file mode 100644
index 00000000000..783e0947977
--- /dev/null
+++ b/community/qt5-qtlocation/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=qt5-qtlocation
+_pkgname=${pkgname/qt5-//}-everywhere-src
+pkgver=5.10.1
+_ver=${pkgver/_/-}
+_ver=${_ver/beta0/beta}
+_ver=${_ver/rc0/rc}
+_V=${_ver/rc/RC}
+pkgrel=0
+pkgdesc="Qt5 - Location component"
+url="http://qt-project.org/"
+arch="all"
+license="LGPL-2.0 with exceptions or GPL-3.0 with exceptions"
+options="!check" # upstream does not provide check
+makedepends="qt5-qtbase-dev"
+subpackages="$pkgname-dev"
+
+case $pkgver in
+*_beta*|*_rc*) _rel=development_releases;;
+*) _rel=official_releases;;
+esac
+source="http://download.qt-project.org/$_rel/qt/${pkgver%.*}/$_ver/submodules/$_pkgname-$_V.tar.xz"
+
+builddir="$srcdir"/$_pkgname-${_V%-*}
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ mkdir -p build
+}
+
+build() {
+ cd "$builddir"/build
+ qmake-qt5 ..
+ make
+}
+
+package() {
+ cd "$builddir"/build
+ make INSTALL_ROOT="$pkgdir" install
+}
+sha512sums="c804de1026d8fd1d98aae2d8ac9e9383414f3d3316637463a059c2ed56e39d66d48126a2ad421df1a747cb4629fa4520a0ff18f56a5597fb6f73e8da7352fa0d qtlocation-everywhere-src-5.10.1.tar.xz"