aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtscript
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-14 14:23:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-14 14:47:01 +0000
commit5b4b0cf8681f025b7f690669d88f2244e3ac0773 (patch)
treeef48215c2fa012e655ee6b731a7e696e92b7ec32 /community/qt5-qtscript
parent8e6d806d685d7ac7b6543f0b1a91b3ca1e327ac1 (diff)
community/qt5-qt*: move from main
Diffstat (limited to 'community/qt5-qtscript')
-rw-r--r--community/qt5-qtscript/APKBUILD47
-rw-r--r--community/qt5-qtscript/qtscript-opensource-src-5.5.0-s390.patch31
2 files changed, 78 insertions, 0 deletions
diff --git a/community/qt5-qtscript/APKBUILD b/community/qt5-qtscript/APKBUILD
new file mode 100644
index 00000000000..6791f4a9ab5
--- /dev/null
+++ b/community/qt5-qtscript/APKBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=qt5-qtscript
+pkgver=5.8.0
+_ver=${pkgver/_/-}
+_ver=${_ver/beta0/beta}
+_ver=${_ver/rc0/rc}
+_V=${_ver/rc/RC}
+pkgrel=0
+pkgdesc="Qt5 - QtScript component"
+url="http://qt-project.org/"
+arch="all !armhf"
+license="LGPLv2 with exceptions or GPLv3 with exceptions"
+depends=""
+depends_dev=""
+makedepends="$depends_dev qt5-qtbase-dev"
+install=""
+subpackages="$pkgname-dev"
+case $pkgver in
+*_beta*|*_rc*) _rel=development_releases;;
+*) _rel=official_releases;;
+esac
+source="http://download.qt-project.org/$_rel/qt/${pkgver%.*}/$_ver/submodules/qtscript-opensource-src-$_V.tar.xz
+ qtscript-opensource-src-5.5.0-s390.patch"
+
+builddir="$srcdir"/qtscript-opensource-src-$_V
+prepare() {
+ local i
+ cd "$builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$builddir"
+ qmake-qt5 && make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir" install || return 1
+}
+
+sha512sums="4eb56c83e8a1826e1a2a36096738a55c702c775a040f09ff2d351527d6cd02a21d48e0f45022691c0e5166aa9881fe70f5596df5eac78c23143ccb829ba54b06 qtscript-opensource-src-5.8.0.tar.xz
+9253275dc268c4b8900dcefb66e6280076dc948bdf0765e0ba3e7c0ec690efaa3c61c5403560a8b4ee9167b43079fff9383e412f8fb912274f410d46fef8acdb qtscript-opensource-src-5.5.0-s390.patch"
diff --git a/community/qt5-qtscript/qtscript-opensource-src-5.5.0-s390.patch b/community/qt5-qtscript/qtscript-opensource-src-5.5.0-s390.patch
new file mode 100644
index 00000000000..e7871f4bc42
--- /dev/null
+++ b/community/qt5-qtscript/qtscript-opensource-src-5.5.0-s390.patch
@@ -0,0 +1,31 @@
+diff -up qtscript-opensource-src-5.5.0/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h.s390 qtscript-opensource-src-5.5.0/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h
+--- qtscript-opensource-src-5.5.0/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h.s390 2015-06-29 15:05:58.000000000 -0500
++++ qtscript-opensource-src-5.5.0/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h 2015-07-16 09:57:18.963167137 -0500
+@@ -226,6 +226,18 @@
+ #define WTF_CPU_SPARC 1
+ #endif
+
++/* CPU(S390X) - S390 64-bit */
++#if defined(__s390x__)
++#define WTF_CPU_S390X 1
++#define WTF_CPU_BIG_ENDIAN 1
++#endif
++
++/* CPU(S390) - S390 32-bit */
++#if defined(__s390__) && !defined(__s390x__)
++#define WTF_CPU_S390 1
++#define WTF_CPU_BIG_ENDIAN 1
++#endif
++
+ /* CPU(X86) - i386 / x86 32-bit */
+ #if defined(__i386__) \
+ || defined(i386) \
+@@ -950,7 +962,7 @@
+ #if !defined(WTF_USE_JSVALUE64) && !defined(WTF_USE_JSVALUE32) && !defined(WTF_USE_JSVALUE32_64)
+ #if (CPU(X86_64) && !CPU(X32) && (OS(UNIX) || OS(WINDOWS) || OS(SOLARIS) || OS(HPUX))) || (CPU(IA64) && !CPU(IA64_32)) || CPU(ALPHA) || CPU(AIX64) || CPU(SPARC64) || CPU(MIPS64) || CPU(AARCH64)
+ #define WTF_USE_JSVALUE64 1
+-#elif CPU(ARM) || CPU(PPC64)
++#elif CPU(ARM) || CPU(PPC64) || CPU(S390X)
+ #define WTF_USE_JSVALUE32 1
+ #elif OS(WINDOWS) && COMPILER(MINGW)
+ /* Using JSVALUE32_64 causes padding/alignement issues for JITStubArg