aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtwebchannel/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-03-10 09:35:17 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-10 23:54:37 -0300
commit818220081d1310d69d0402799ce72b5f5a775fb3 (patch)
tree885249d12570045dfc53c6cfd895f65fb35c941e /community/qt5-qtwebchannel/APKBUILD
parent8f90cf87c9b0a22e7ccdb8f5cd221b1c75377952 (diff)
community/qt5-qtwebchannel: take over maintainership
Also sync APKBUILD with other Qt packages
Diffstat (limited to 'community/qt5-qtwebchannel/APKBUILD')
-rw-r--r--community/qt5-qtwebchannel/APKBUILD35
1 files changed, 15 insertions, 20 deletions
diff --git a/community/qt5-qtwebchannel/APKBUILD b/community/qt5-qtwebchannel/APKBUILD
index 3db7c99b6af..87d48f1bfb1 100644
--- a/community/qt5-qtwebchannel/APKBUILD
+++ b/community/qt5-qtwebchannel/APKBUILD
@@ -1,42 +1,37 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=qt5-qtwebchannel
pkgver=5.14.1
-_ver=${pkgver/_/-}
-_ver=${_ver/beta0/beta}
-_ver=${_ver/rc0/rc}
-_v=${_ver/rc/RC}
-pkgrel=0
+pkgrel=1
pkgdesc="library for seamless integration of C++ +and QML applications with HTML/JavaScript clients."
url="https://www.qt.io/developers/"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
-options="!check" # upstream does not provide check
+options="!check" # No tests
makedepends="qt5-qtbase-dev qt5-qtwebsockets-dev qt5-qtdeclarative-dev"
subpackages="$pkgname-dev"
+builddir="$srcdir/qtwebchannel-everywhere-src-$pkgver"
case $pkgver in
-*_beta*|*_rc*) _rel=development_releases;;
-*) _rel=official_releases;;
+ *_beta*|*_rc*) _rel=development_releases;;
+ *) _rel=official_releases;;
esac
-source="https://download.qt.io/$_rel/qt/${pkgver%.*}/$_ver/submodules/qtwebchannel-everywhere-src-$_v.tar.xz"
-builddir="$srcdir"/qtwebchannel-everywhere-src-${_v%-*}
-
-prepare() {
- default_prepare
-
- mkdir -p "$builddir"/build
-}
+source="https://download.qt.io/$_rel/qt/${pkgver%.*}/$pkgver/submodules/qtwebchannel-everywhere-src-$pkgver.tar.xz"
build() {
- cd "$builddir"/build
- qmake-qt5 ..
+ qmake-qt5
make
}
package() {
- cd "$builddir"/build
make INSTALL_ROOT="$pkgdir" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/$pkgname
}
sha512sums="7abe214227efcea665a38488b73286ae8335490d825dd8886270e2c1cbf7382e27d6ec368b28f9876d6843029023a63e58f42e2bdb6aeb1502ae464af3e8666e qtwebchannel-everywhere-src-5.14.1.tar.xz"