aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtwebchannel/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-05-01 11:21:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-01 11:40:27 +0000
commit344a93722265afabe64db1717946a34e7e1abb67 (patch)
treea167c20f232602e8b6f01dea68335d9d8d0756af /community/qt5-qtwebchannel/APKBUILD
parent64cfe4271b99b346203b1f218796067d9a131aa5 (diff)
community/qt5-qt[various]: move from testing
Diffstat (limited to 'community/qt5-qtwebchannel/APKBUILD')
-rw-r--r--community/qt5-qtwebchannel/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/qt5-qtwebchannel/APKBUILD b/community/qt5-qtwebchannel/APKBUILD
new file mode 100644
index 00000000000..b129cbb3280
--- /dev/null
+++ b/community/qt5-qtwebchannel/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=qt5-qtwebchannel
+_pkgname=${pkgname/qt5-//}-everywhere-src
+pkgver=5.10.1
+_ver=${pkgver/_/-}
+_ver=${_ver/beta0/beta}
+_ver=${_ver/rc0/rc}
+_V=${_ver/rc/RC}
+pkgrel=0
+pkgdesc="library for seamless integration of C++ +and QML applications with HTML/JavaScript clients."
+url="http://qt-project.org/"
+arch="all"
+license="LGPL-2.0 with exceptions or GPL-3.0 with exceptions"
+options="!check" #upstream does not provide check
+makedepends="qt5-qtbase-dev qt5-websockets-dev qt5-qtdeclarative-dev"
+subpackages="$pkgname-dev"
+
+case $pkgver in
+*_beta*|*_rc*) _rel=development_releases;;
+*) _rel=official_releases;;
+esac
+source="http://download.qt-project.org/$_rel/qt/${pkgver%.*}/$_ver/submodules/$_pkgname-$_V.tar.xz"
+
+builddir="$srcdir"/$_pkgname-${_V%-*}
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ mkdir -p build
+}
+
+build() {
+ cd "$builddir"/build
+ qmake-qt5 ..
+ make
+}
+
+package() {
+ cd "$builddir"/build
+ make INSTALL_ROOT="$pkgdir" install
+}
+sha512sums="aea4c82d3873be24aa1648e197d6b3403f11658793dff40fe37cd3726a34360286638424cba83de530049e4ff5a69d9f251cb105c65da5142376dc2827510d47 qtwebchannel-everywhere-src-5.10.1.tar.xz"